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Welcome 
 

This document explains the installation and operation of Easypano Panoweaver 7.20. 
It is intended for both newbies and professionals who engage in online panorama 
and virtual tour building. 

 
Conventions and Definitions 
Copyright Announcement 
Feedback 

 

 
 

Conventions and Definitions 
We use the following typographical conventions and definitions in this document: 

 

Typeface or Icons Purpose 
Italic Used to emphasize new terms and 

concepts at the point where they are 
introduced. Also used to designate the 
quoted terms or menus of the software.

Note 
Used to arouse the readers' attention 
towards certain operations or things 
they should consider. 

 
Tip 

Used to offer some extra techniques on 
how to use Panoweaver. 

 
 
 
Copyright Announcement 

This manual, as well as the software described in it, is furnished under license and 
may be used or copied only in accordance with the terms of such license. The  
content of this manual is furnished for informational use only, is subject to change 
without notice. Easypano assumes no responsibility or liability for any errors or 
inaccuracies that may appear in this documentation. Except as permitted by such 
license, no part of this publication may be reproduced, stored in a retrieval system, 
or transmitted, in any form or by any means, electronic, mechanical, recording, or 
otherwise, without the prior written permission of Easypano. 
 
Panoweaver 7.20 and Easypano are trademarks of Easypano Holdings Inc. Microsoft, 
Windows, Macintosh and Internet Explorer are registered trademarks of other 
Corporation. About more on license information please refer to the license 
agreement included in the applications. Other products mentioned in this manual 
have rights and marks held by their respective owners.  

 
 
 

Feedback 
We welcome your comments and feedback on this manual. Please send your 
comments to us by email:  support@easypano.com or visit the Help Desk or select 
Help > Bug Report/Feature Request to submit. 

mailto:support@easypano.com
http://www.easypano.com/helpdesk.html
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Introduction 
 

 
Panoweaver 7.20 comes in three editions: Standard, Professional and Batch. 

Note: For the help info about Standard edition, please refer to the Help Topics 
in Standard edition. 

 

What's New 

 
 
Panoweaver can stitch regular or fisheye images into 360° panoramic images. 
Compared with traditional plane image, panoramic image provides 360° field of view 
to make viewer feel like in the scene physically. As a result, it is widely used in 
exhibition business, for instance, real estate, tourist scene, automobile, hotel, campus, 
culture site and gymnasium. In addition, panoramic image can also be used as a 
record tool in emergency plan, real estate management, map and other business. 
Compared with words and plane image, panoramic image is more vivid to record 
comprehensive information. 

 
 
What’s New in Panoweaver 7 
Added features 
Support removing tripod from panorama by using additional shot .  
Support removing tripod directly in Panoweaver  
Provide selection of stitching parameters 
Support output of six cubic images   
Support adding hotspot (not supported in std edition)  
Support background music (not supported in std edition) 
Support adding print, emailto, show help, play sound buttons (not 
supported in std edition) 
Support customization of URL link on context menu (not supported in 
std edition)  
Support swf progress bar (not supported in std edition) 
Support stitching of big-sized panorama (not supported in std edition) 
Support Html5 format output 

Shooting Tip: 

1. Shoot additional ceiling/floor shots without tripod to replace the original shots.  
2. When shooting ceiling/floor, shooting position should be almost the same with 
the original position. The degree difference between the two positions should be 
limited in 20 degree. 
3. Then click Stitch to get a panoramic image with tripod removed.  
 

Improved features 
Improved stitching effect 
  

Removed features 
Delete Prestitch 
 



5 

For the latest info about What's New, please refer to What's New. 

http://www.easypano.com/Panorama-software-53_462.html
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Edition Comparison 

In order to cater for different user groups, Panoweaver 7.20 is designed to develop 
three editions involving Professional, Standard and Batch edition. The two editions 
(Batch and Pro) possess almost the same functions, which are all powerful and 
professional tools to stitch panoramas. The batch version has all features of the pro 
version and additionally supports batch stitching. Functionality only present in the 
Batch version is donated in the manual by [Panoweaver Batch only]. For the sake of simplicity, 
this manual refers to Panoweaver when discussing functionality that is common to 
Professional and Batch version. Below is the comparison between the two editions. 
 
Panoweaver 7.20 Edition Comparison 
 

Features Batch Professional Standard 

Support all kinds of camera 
(normal lens, wide angle lens, 
raynox lens, sunex lens and 
fisheye lens)  

  
Only support 

normal and wide-
angle lens  

Auto stitch spherical and 
cylindrical panorama     

Manual stitching     

Support two blenders: PWBlend 
and SmartBlend    

Only support 
PWBlend  

Stitch multiple rows of images    

Stitch 16 bit image     

Full circular    

Drum     

Full frame     

Cube face     

Raynox    

Wide-
angle/Normal    

Source image 
type  
 

Camera Raw     

Create HDR image to solve 
overexposure/ underexposure 
problem  

   

http://www.easypano.com/pw6-equipment.html
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Support removing tripod New    

Support stitching of big-sized 
panorama New    

Batch stitch, publish, and 
Spherical/Cubic conversion     

Provide selection of stitching 
parameters New    

Support output of six cube face 
images New    

Add hotspot to panorama New    

Flash    

Java applet     

QTVR    

Shockwave 
Flash 
(Standalone 
SWF) 

   

Publishing 
format  

 

HTML5  New    

Flash     

Java applet     

Full screen  

 

QTVR    

Right click stitching     

Customize ceiling/ floor logo    

Customize Loading Window for 
Flash VR and Standalone swf 
output 

   

Support swf progress bar New    

Support background music New    

Support adding print, emailto, 
show help, play sound buttons 
New 

   

Support customization of URL 
link on context menu New    
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Generate files for autorun CD     
 

Get Help 

 

 
 
Easypano provides a variety of options for getting help and learning Panoweaver. 
Before you contact technical support, have you: 
 Referred to the information of this Panoweaver 7.20 user manual (To start the 

online Help, select Help > Help Topics from the main menu or press F1). 
 

 Read the Troubleshooting section of this manual. 
 

 Visited the support column for updated troubleshooting information: The FAQ 
and Knowledge Base section of the Support column deal with issues that are 
outside of the scope of the standard documentation, such as compatibility 
issues, licensing questions, and a variety of common problems. 

 
 Visited the Help Desk or select Help > Bug Report/Feature Request for 

technical support. 
If you still have problems after the above steps, you could email to us: 
support@easypano.com or contact us via  other ways. 

http://www.easypano.com/product-documents.html
http://www.easypano.com/support_index.html
http://www.easypano.com/faq.html
http://www.easypano.com/faq.html
http://www.easypano.com/kb.html
http://www.easypano.com/helpdesk.html
mailto:support@easypano.com
http://www.easypano.com/live-support.html
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Install Panoweaver 7.20 
 
 
 

System Requirements (For Windows) 

To use Panoweaver 7.0 in Windows, you need: 
 
Operating System 

 Microsoft Windows 2K/XP/Vista/7 
Computer Hardware 

 PIII 800MHz, AMD 2800+ or faster processor 
 1G RAM or more 
 Network card or modem must be installed 
 100M of free hard disk space or more (300M of free hard disk or more is 

required for generating HDR image) 
 Video display of 800x600 pixels or higher (1024x768 is suggested), 16-bit 

colors or higher supported 

Note: 2G RAM or more is recommended to stitch panorama over 10000*5000 
or to get HDR image. 

 
Others 
 

 OpenGL 1.2 or above is required 
 
 
 
To view panoramas in Windows, you need: 
 
Operating System 

 Microsoft Windows 2K/XP/Vista/7 
Computer Hardware 

 PII 400MHz or faster processor 
 128MB free memory 
 Video display of 800x600 pixels or higher (1024x768 is suggested), 16-bit 

colors or higher supported 
Others  

Microsoft IE6.0, Netscape Navigator 7.0, Firefox 1.0 or later version 
To view Flash VR, flash player 9.0 is necessary. Please download Flash Player 
9.0 and install it. 
To view panorama with Easypano virtual tour player, Java Virtual Machine is 
necessary. Please download  Microsoft JVM  or Sun JRE and Install it. 
To view QTVR, QuickTime 6.0 or later version is necessary. Please download 
QuickTime player.

 

http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash
http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash
http://www.easypano.com/download/msjavx86.exe
http://www.java.com/en/download/index.jsp
http://www.apple.com/quicktime/download/
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System Requirements (For Macintosh) 

To use Panoweaver 7.0 in Macintosh, you need: 
 
Operating System 

•  Macintosh OSX 10.4 or later version 
Computer Hardware 

•  G4 or higher 
•  1G RAM or more 
•  Network card or modem must be installed 
•  100M of free hard disk space or more (300M of free hard disk or more is 

required for generating HDR image) 
•  Video display of 800x600 pixels or higher (1024x768 is suggested), 16-bit 

colors or higher supported 
 

Note: 2G RAM or more is recommended to stitch panorama over 10000*5000 
or to get HDR image. 

 
Others 

•  OpenGL 1.2 or above is required 
 
To view panoramas in Macintosh, you need: 
 
Operating System 

•  Macintosh OSX 10.2 or later version 
Computer Hardware 

•  G3-400MHz or faster processor 
•  512MB free memory 
•  Video display of 800x600 pixels or higher (1024x768 is suggested), 16-bit 

colors or higher supported 
Others 

•  Microsoft IE6.0, Netscape Navigator 5.0, Firefox 1.0 or later version 
•  To view Flash VR, flash player 9.0 is necessary. Please download Flash Player 

9.0 and install it. 
•  To view panorama with Easypano virtual tour player, Java Virtual Machine is 

necessary. Please download  Microsoft JVM or Sun JRE and Install it. 
•  To view QTVR, QuickTime 6.0 or later version is necessary. Please download 

QuickTime player. 
 
 
 

Install Panoweaver 7.0 Trial Version 

1. Download the trial version of Panoweaver 7.20 from Easypano website.      
2.  Close all other Windows applications which are currently running. 
3. Double click the Panoweaver installation package to run the installation 

application. 

http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash
http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash
http://www.easypano.com/download/msjavx86.exe
http://www.java.com/en/download/index.jsp
http://www.apple.com/quicktime/download/
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1.  Click Next to go to the License Agreement. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2.  Accept the License Agreement and click Next. 
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3.  Select the folder where you wish to install Panoweaver then click Next to 
continue. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4.  It will be ready to install. 
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5.  Click Install to start installing the Panoweaver software. 
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6.  Click Finish to complete the installation. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Uninstall Panoweaver 7.0 
There are two ways to uninstall Panoweaver: 

•  Use shortcut in Start menu. Start>Programs>Easypano>Panoweaver 7 
Professional Edition>Uninstall. 

•  Click Add/Remove Program in Control Panel to uninstall. 
 
 
 
 

Activate Panoweaver 7.20 
 

 

Purchase 

To use the full features of Panoweaver, you need to buy a license key to activate the 
software. Visit Easypano Online Store to get information on purchasing. One license 
key can be used to activate the software installed on two computers. 

 
 

Product Activation 

Online Activation 
Offline Activation 
 
To fight against piracy and better protect Easypano copyright as well as users' 
interests, we adopt a stricter license policy. Easypano customers have to activate 

http://www.easypano.com/onlinestore.html
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the product to make it fully functional. The Easypano Product Activation System 
does not collect or utilize personal information, such as your name and contact 
information. Product Activation is completely secure and anonymous. No personal 
information is ever collected or requested. During activation, the product does not 
scan your hard drives or collect any data other than the minimum information 
required to verify your license. Please see our Privacy Policy. 

 
 
Online Activation 
If the computer you are running Easypano software is connected to Internet, please 
proceed with the online activation. Activation over the Internet is a one-time 
operation. Simply enter your product serial number and activate for full use in 
seconds, secure and anonymous. 

Note: Online Activation requires network card and Internet connection. 
•  Start Panoweaver 
•  Choose online activation in the popup window and then click Continue 
•  Input the license key which you’ve purchased and click Continue 
•  The online activation is accomplished. 

Offline Activation 
In case you need to run Easypano products in a computer without Internet 
connection, you can find some other computer with Internet available to activate 
the product via Email or Easypano website submission. Since Internet is quite 
pervasive nowadays, we assume all the customers can access the Internet by 
certain means, either in a net cafe, or another computer. 

 
Basically offline activation still requires internet connectivity, however not 
necessarily in the computer running the software. 
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A general procedure for offline activation: 
1.  Start Panoweaver. 
2.  Choose offline activation in the popup window and then click Continue. 
3.  Choose step 1 to create an ARF file and click Continue. 

4.  Input the license key you’ve purchased and select the right directory to save 
this ARF; and click Continue. 

5.  An ARF file is created and saved in the relative path. 
6.  Click the link to open the registration html page. Fill out one or two available 

Email and upload this ARF. 
7.  An ALF file is created and sent to the relevant Email. 
8.  Log in to your email-box and save this ALF to your local. 
9.  Restart the activation procedure from Help menu. 
10. Choose offline activation; and click Continue. 
11. Choose step 3 and click Continue. 
12. Import ALF to activate the software and click Continue. 
13. Offline activation is accomplished. 

Note: Offline Activation requires network interface card installed. 
 
Please make sure the computer on which you install Panoweaver and create 
Activate Request File, meets following requirements. 

1.  Network card is installed. 
2.  TCP/IP protocol is installed. 
3.  Network card is not disabled. 

 
 
 

Transfer License Key 

If you want to move your software from current computer to a new one or plan to 
upgrade your hardware, transferring license should be done in advance. This 
feature deactivates the product on your current machine so it can be reactivated on 
the new or upgraded computer. 

 
Transfer License Mechanism: 
1.  Run Transfer License 
2.  Activation ID and Serial Number are uploaded to Easypano Activation Server 
3.  Activation Server checks the Activation ID 
4.  Activation Server deactivates the current product and gives feedback to you. 
 
Please click Help>Transfer License, it can be finished in a moment. 

Note: Internet connection is required to transfer license. In case you need 
transfer license offline, say the original computer can not be accessed or crashed, 
please directly contact  support@easypano.com. An inclusion of your serial number 
in the email will be more helpful. Easypano support will transfer your license in 
original computer so that you can reactivate in another one. 

 
Tip: Only when the product was activated, can users proceed to transfer 

license. 

http://www.easypano.com/activation.html
mailto:support@easypano.com
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Basic Knowledge of Panoweaver 7.20 

About Panoweaver Project File 

Project still exists in Panoweaver 7.20 as in Panoweaver 6.00. So you may save 
unfinished panoramic image as a .pw file and continue to edit it later. For details, 
please refer to  Project. 

Note: The project file generated from Panoweaver 6.00 can't be applied in 
Panoweaver 7.20. 

 

User Interface 

User Interface of Panoweaver 7.0 mainly includes 5 parts: Menu Bar, Toolbar, 
Image Show and Operation Area, Panel and Status Bar. 

 

Menu Bar 

This section gives an overview of the menu commands and related keyboard 
shortcuts of Panoweaver 7.20. If a shortcut is available, it is shown next to the 
function. 

 
1. File menu 

 

File menu Feature Description Shortcuts 
New Project Start a new project 

(import images) 
Ctrl +N 

Open Project Open an existing project 
(.pw file) 

Ctrl +O 

Close Project Close the current project 
 

Ctrl +C 
 

Save Project Save the current project Ctrl + E 

Import Panoramic Image Load panoramic image Ctrl + I 

Save Project As Save the current project 
under a different name 

- 

Preview Preview a panorama Ctrl + R 

Save Panoramic Image Save the generated 
panoramic image 

Ctrl + S 

Publish Publish a panorama Ctrl + B 

Exit Exit Panoweaver Ctrl + Q 
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2. Panorama menu 

 

Panorama menu Feature Description Shortcuts 
Spherical/Cubic Conversion Convert from cubic panorama 

to spherical one or vice versa
Ctrl + F9 

Save Stitching Parameters Save Stitching Parameters 
after finish stitching and 
name the parameter 

Ctrl + W 

Manage Stitching Parameters Make adjustments to the 
Stitching Parameters 

- 

Stitch Stitch panorama directly Ctrl + F5 
Strong Algorithm 
 

Deal with unsuccessful stitching 

Tip: It is suggested stitching 
with Strong Algorithm when 
matching points are not enough 
during default stitching. 

Ctrl + Alt + F5 
 

Last 
Parameter 

The parameter saved last 
time after stitching 

Ctrl + L Stitch with 
Former 
Parameters Former 

Parameter 
List all the saved parameters 
in the Manage Stitching 
Parameters window 

- 

 
 
 

3. Image menu 
 

Image menu Feature 
Description 

Shortcuts 

Zoom In Zoom in the image Ctrl + + 
Zoom Out Zoom out Ctrl + - 

View 

Best Fit Display an image 
at a proper 
percentage 
depending on the 
size of display 
window. 

Ctrl + 0 

90CW 90 degree 
clockwise rotation 

- 

90CCW 90 degree 
counterclockwise 
rotation 

- 

Rotate 

180 180 degree 
rotation 

- 
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Horizontal Flip horizontally - Flip 
Vertical Flip Vertically - 
Color Balance Adjust color 

balance 
(panoramic image 
only) 

- 

Brightness/ 
Contrast 

Adjust brightness 
and contrast 
(panoramic image 
only) 

- 

Adjust 

Hue/ Saturation Adjust hue and 
saturation 
(panoramic image 
only) 

- 

Blur Blur a panoramic 
image 

- Filter 

Sharpen Increase contrast 
in a panoramic 
image 

- 

 
 
 

4. Tools menu 
 

Tools menu Feature 
Description 

System Defaults System default 
language 

Language 

Multilanguage List Choice of 
multilanguage 

Advanced Settings Advanced 
Settings 

 
 
 

5. Help menu 
 

Help menu Feature Description Shortcuts 
Help Topics Opens the help file of 

Panoweaver 
F1 

www.easypano.com Visit easypano.com 
website for more 
information 

- 

Check for Update Check if there is an 
updated version available

- 

http://www.easypano.com/
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Bug Report/ Feature 
Request 

Submit Bugs or feature 
requests 

- 

Buy Now Purchase in online store - 
Easypano Product 
Activation 

Activate Panoweaver with 
your serial number 

- 

Transfer License Transfer license to a new 
computer 

- 

About Easypano 
Panoweaver 

Copyright information of 
Panoweaver 

- 

 
 
 

Note: Some of the drop-down menu functions are available directly through 
toolbar icons. 

 
 
 
 

Image Show and Operation Area 

 

 
 

Image show and operation area shows selected still or panoramic images. You may 
make the manipulations such as zoom, rotation and edit within this area. 

 
 
 
 

Source Images Tab 

 
 
Thumbnail View 
Editable Original Image View 
Matching Points Editing View 
 
Thumbnail View 
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Feature Description 

: Sort all images by a certain order (by Name, by Date, by Load Order). The order 
will be a reference to stitching. 

: Exclude the selected image from stitching process (The disabled image is grayed 
out). 

: Add one or more images to the current project. 

: Delete the selected images. 

: Rotate the selected images 90 degree counterclockwise. 
: Rotate the selected images 90 degree clockwise. 

 
: Adjust size of thumbnails. The display dimension range of a single 

thumbnail image is 75x75~290x290, 120x120 by default. 
 
 

Tip: The first thumbnail image is selected by default. Select one or more images 
and drag to change position. 

 
 
 
Editable Original Image View 
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Feature Description 

: Set the image display proportion. The available range is 3%~800%. 
Best Fit: Display the image at a proper percentage depending on the size of display 
window. 

Navigation chart: Navigation Chart shows thumbnail of the image in Image Show 
Area. Drag the Move handle to move the chart. 

 
How to zoom in/zoom out image? 

 Use Ctrl+ “+” (zoom in) and Ctrl+ “-” (zoom out). 
 Use Image>View>Zoom In/Zoom Out in Menu bar. 

 Click arrow under , select scaling value in drop down list. 
 Locate the mouse in the combobox and roll the mousewheel to scale the 

image. 

 Double click the figure under , revise it and then press enter. 
How to move image within Image Show Area? 

 Hold down left mouse button and drag; 
 Use Navigation Chart button. If you move Navigation Chart, image’s location 

in Image Show Area will change simultaneously. 
 
 

Tip: 
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If you right click on Image Show Area, the following menu will appear, which has 
the same function as Image in Menu bar. See below: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

  If the imported images are Circular or Drum images, you need to adjust a Circle 
surrounding the fisheye images, please refer to  Set Fisheye Image Enclosing for 
details: 

 
 
 
 
 
Matching Points Editing View 
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Feature Description 
 

/ : Auto match/Disable auto match. After placing one matching point, move the 
mouse pointer to the expected location of the matching point automatically. 

: Display the image at a proper percentage depending on the size of 
display window. 

 
As to how to use the matching points panel below, please refer to  Use Matching  
Points Panel. 

 
 
 
 
 
 
 
 
 
 
 
 
 

Tip: When you click the image tag on the left, it will be marked in black, and the 
related images on the right are marked in red. 

Note: If the matching points in Matching Point Table is marked in red, it means 
the distance is too large, deleting the pair of points before stitching. If the effective 
matching points are less than three pairs, insert matching points manually. 

 
 
 
 

Panoramic Images Tab 
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Panorama in Flat View 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Feature Description 
 

: 
Best Fit: Display the image at a proper percentage depending on the size of 
display window. 

 
 

Tip:  To move the image by holding down the mouse and dragging. If you right 
click on the panoramic image, the following menu will appear. See below: 
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Panorama in Immersive View 

 
 
 

: To set panorama properties 

 
  If previewing an imported panoramic image, the button is active, otherwise, it's 

disabled. 
  As for Panorama Type, there are 3 options available--spherical, cylindrical and 

cubic panorama. 
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Panfov: If the imported panoramic image is spherical or cubic one. 360 is by 
default. If the imported panoramic image is a partial cylindrical one, and the panfov 
can be customized. 

: The option is disabled. 
See Preview Panorama. 

 

Note: 

1. Select File>Preview or click on Preview button from toolbar to enter 
Immersive View to preview a panorama. 
2. Support preview of spherical (with ratio of 2:1 or 1:1), cubic or cylindrical 
panorama. 

 
 
 
 

Panel 

 

 
 
Image Type 
Set image type in this panel, and the info displayed in Image Type and Hor. FOV 
fields is calculated according to the read EXIF data info. For details, please refer to 
Set Image Type. 

 
 
Fisheye Image Enclosing 
You are able to adjust Center and Radius of fisheye enclosing in this panel. For 
details, please refer to  Set Fisheye Image Enclosing. 

 
 
Panorama Type 
You are able to set type and size of the panoramic image that you want to get in this 
panel. For details, please refer to  Set Panorama Type. 
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Ceiling/Floor 
You are able to add or remove Ceiling/Floor logo in this panel. For details, please 
refer to  Add Logo. 

 
 
 
 
 

Status Bar 

After each operation is finished, relative information will show on this bar. If you 
click a picture, the operation info, name of the picture, format, size and shutter, 
aperture, compensation value will be shown in this bar. 

 
 

 
 

 
 
 
 

My First Panorama 
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Shoot Images 

Before we get to stitching however, it's important that we start with proper source 
images. Panoweaver 7.20 supports normal lens, wide-angle lens and fisheye lens. It 
can handle almost every kind of image (one row or multiple rows of images), in any 
orientation. 

 
Shoot with Normal Lens or Wide-angle Lens 
Basic steps: 

1.  Set your photographic equipment in place: a tripod, a pano head and a 
camera. 

2.  Adjust the nodal point. 
3.  Shoot images. 

 
Tip: 1. To get the best result inside a building for professional use, please note: 
     A tripod and a panoramic pano head are suggested while shooting. Handhold 

shooting is not suggested. 
     As well, the nodal point should be adjusted precisely. 

2. If you want to shoot far away objects outside a building and only one row 
of pictures for stitching, handhold shooting can also be applied. 

 

 
For the best results please remember the following key points: 

All images should be taken from the same viewpoint. 
This is the most important thing to consider when photographing for panoramas. A 
panorama can only be successfully stitched from images that are taken from 
exactly the same viewpoint. If the camera has been moved between shots, 
parallax error may be caused, which should be avoided at any cost. You can shoot 
hand held, but using a tripod makes it much easier to maintain the camera position. 
You can see the effects of parallax error with the experiment. 

 
For a camera, the nodal point of the lens should be kept in the same position. 
Unfortunately the nodal point never coincides with the camera's tripod mount hole. 
For proper nodal point alignment on a tripod therefore a panoramic head should be 
used, which shifts the axis of rotation of the camera to a desired point. The severity 
of parallax errors depends on the proximity of objects to the camera. A scene with 
only far away objects is forgiving to nodal point misalignment. Therefore, if you are 
unsure of the nodal point alignment of your camera, it's best to start with a 
landscape scene, not a panorama taken inside a building. 

 
 

Tip:  How to find the nodal point of a lens? 
     Lock the camera's exposure and white balance. 

Although Panoweaver compensates for exposure differences, you will get the best 
results if there are no brightnessor color differences in the images. 

 
Please use the sample normal images taken handheld, with a digital SLR camera. 
Download the images for this tutorial. 
 

 
Shoot with Fisheye Lens 
Basic steps: 
1. Decide the type of fisheye image that you want to shoot. 

http://360texas.com/tips/nodalpts.htm
http://www.easypano.com/download/samples.zip
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2. Select proper photographic equipment. Please refer to  Main Photography  
Equipment. 
3. Shoot fisheye image. Please refer to  Workflow of Shooting Fisheye Images. 

 
Type Qt. of Image Way of Shooting 
Drum 4, 4+T, 4+B, 4+T+B 4 pictures in portrait 

mode 
6, 6+T, 6+B, 6+T+B 6 pictures in portrait 

mode 
Full Frame 

4, 4+T, 4+B, 4+T+B 4 pictures in landscape 
mode 

Full Circular 1, 2, 3 as you like 
 

Tip: T refers to Top fisheye image which can be obtained through rotating 
camera up to shoot. B refers to Bottom fisheye image which can be obtained 
through rotating down to shoot. 

 
For more details, please see  Panorama Photography 
 
 
 
 

Stitch Panoramic Image 

 

 
 

Even if this is your first time to use Panoweaver, you don’t have to worry about the 
manipulation because Panoweaver will stitch images automatically. Just follow the 
default settings, and then you will obtain a satisfactory panorama within several 
minutes. 

 
Basic steps: 

http://www.easypano.com/Panorama-software-47_384.html
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1. Select File>New project or click on toolbar to import the source images. 

2. Select Panorama>Stitch or click on toolbar to stitch the images. 

3. Select File>Preview or click on toolbar to preview panorama. 

4. Select File>Save Panoramic Image or click on toolbar to save panorama. 

5. Select File>Publish or click on toolbar to publish panorama. 
 
 
 
 

Application 

After publishing panoramic image, you are able to upload it to website (refer to 
Upload to Website); or you may import panoramic image into Tourweaver to make 
virtual tour (refer to Make Virtual Tour with Tourweaver). 

 
 
 
 
 
 
 

Use Panoweaver 7.20 
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Import Images 
Stitch Panoramic Image 
Add Hotspot to Panorama 
Edit Panoramic Images 
Preview Panorama 
Save Panoramic Image 
Publish Panorama 
Project 
Advanced Settings 
Get HDR Image 
Batch Processing 
 
 
 
 

Import Images 

 

 
 

Select File>New project or click on toolbar to import the source still images. 
Finally click Open: 
1. Select file format (jpg, .tiff, .bmp, or png). 
2. Select number of images from file list. 
3. Click Open. 

 
 
 
Type of Files: 
Panoweaver 7.20 supports importing the following formats: 

 

Types Remarks 
Camera Raw (*. NEF; *. CRW; *. Dng; *ARW)  
JPEG Image Format (*. jpeg; *. jpg) By default 
Portable Network Graphics (*. png) 8bit 
Tiff Image Format (*. tiff; *. tif) 8bit/16bits 
Windows Bitmap (*. bmp); Pict for 
Macintosh (*. pict) 

8bit 

All Image Format  
For details about RAW, please refer to  Import Raw File. 

 
Preview: 
To preview selected image before importing, select the checkbox in front of Preview. 
 

Note: Cube Face requires 6 square images (the ratio of width to height is 1:1). 
These images can be obtained by modeling or by cubic panoramic image stitching. 
The importing sequence should be front, right, back, left, top and bottom. The 
sketch map is 
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Stitch Panoramic Image 

 

 
 

Parameters Setting about Stitching 

 

 
 
Set Image Type 
Set Fisheye Image Enclosing 
Use Matching Points Panel 
Set Panorama Type 

 
 
 

Set Image Type 

 
 

 
 
 
Basic Steps: 
 
1. Select the calculation method of camera and lens parameters. When Automatic is 
selected, automatic calculation will be displayed in the items 2 and 3. When Custom 
is selected, the items 2 and 3 are editable. 

 
 
2. Image Type: To display or set the image type, including Circular Fisheye image, 
Drum Fisheye image, FullFrame Fisheye image, Wide-angle image and Normal 
image. 
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Image Type Default Hor. FOV 
(degree) 

Circular Fisheye 180 
Drum Fisheye 120 
FullFrame Fisheye 88 
Wide-angle/Normal 50 
Raynox 188 
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Note: Only stitching of three raynox images is supported. 
 
3. Hor. Fov: To display or set the horizontal FOV value. The default horizontal FOV 
varies with different image types. See the above chart. 

 

Note: If EXIF data was not found in the image(s), a dialog box will pop up like 
below. Please select an image type in this kind of situation. 

 
 
 
 

Note: Information about the camera and the lens can be stored in the EXIF data 
inside a JPEG file, but not all cameras include the EXIF data. Further, EXIF data may 
be lost if the image is modified in a graphics application. If the data can't be found 
in the image during reading the info about EXIF data, a dialog box will pop up with 
prompt info "EXIF data was not found in the image(s). Please select the image 
type!", then please select an image type by yourself. 
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Set Fisheye Image Enclosing 

This is an important step to get the high quality panorama. This function is only 
applicable to drum and full circular fisheye images. 
 

 
 
 
Basic Steps: 

1.  Select an image and zoom it to proper size in Image Show and Operation 
Area. 

2.  Drag the yellow circle properly around the fisheye image in the panel to 
change radius. Press Ctrl+Left Mouse Key to change center. 

3.  Adjust Center X, Center Y, Radius to locate the yellow circle around the 
fisheye image, no more and no less. Center X stands for the x coordinates of 
the enclosing. Center Y is the y coordinates of the enclosing, while Radius 
refers to the circle’s radius. Click , yellow circle moves up; click , yellow 
circle moves down; click , yellow circle moves left; click , yellow circle 
moves right; click , yellow circles zooms in; click , yellow circle zooms 
out. 

4.  Generally, if a group of fisheye images are shot with the same equipment, 
the setting parameters of one image are applicable to the other images. 
After you adjust the yellow circle, you may select √ before Apply to All 
Images to implement the parameters to the other images. 

 
 

Tip: If you want to use parameters of the latest fisheye image as initial value in 
new image, please select Last Used in Advanced Settings. Panoweaver will apply the 
parameters to current image. Usually, the default item is Auto-calculated, that is, 
Panoweaver will select the location and size of yellow circle automatically whenever 
you import fisheye images. For details, please refer to  Advanced Settings. 

 
 
 
 

Use Matching Points Panel 

You may see matching points’ parameters of each pair of images in this panel  in  
Editable Original Image View under Source Images Tab. For details of inserting 
matching points, please refer to  Insert Matching Points. 
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1. Matching Point Table: 
To display the matching points of a current image pair. For the details about 
operations on matching points, please refer to  Insert Matching Points. 

 
2. To display the feedback info of the calculation result of stitching 
parameters. 
There are two kinds of tips to remind you what to do next after stitching. 

 #0200011Calculation of stitching parameters fails! It may be caused by: a) 
existing orphaned images; b) matching points of image pairs with big error 
or with less than 3 pairs. Please try another stitch after adjusting the points. 

 Enough matching points! 
3. To list different association relations among image pairs after searching 
for matching points and optimization. Click on the number hyperlink beside these 
items, the corresponding image will display in the show area on the left side. 

 Orphaned Images: The images listed under this item don't have any 
matching point with other images. 

 Linked Image: The images are linked through matching points. 
 Image pairs with less than 3 pairs of matching points: To list all the 

image pairs with less than 3 pairs of matching points. In this case, you need 
to add a few matching points by hand. If the number of the matching point 
pairs in an image pair is greater than or equal to 3, then the image pair will 
be listed under Linked Images. 

 

Tip: 
      When the matching points change or images are added/deleted, the list info 

will change accordingly. For example, the no. 6 image first is listed under 
the item Orphaned Images. After matching points are added to the image, 
it will automatically go under the item Linked Images. 

      If all the images are listed under the item Linked Images, and under the 
other items, there isn’t any listed image, in this case, a successful stitch will 
be easily achieved. 

 
 
 
 

Set Panorama Type 

 
 
You are able to set type and size of the panoramic image that you want to get in this 
panel. There are three types: Spherical Panorama, Cubic Panorama, Cylindrical 
panorama. 
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Basic Steps: 

1. Set panoramic image type. 
Spherical Panorama: The ratio of width to height is fixed at 2:1. 
Cubic Panorama: The ratio of width to height is fixed at 6:1. 
Cylindrical Panorama: No fixed ratio. 

 
2. Set panoramic image size. 
Panoweaver provides several sizes for common use. Select from the drop down 
menu to decide the image size. Certainly you may also customize size by yourself. 

 

Web Dialup Spherical Panorama 1400x700 
 Cubic Panorama 2400x400 
 Cylindrical Panorama 25% of Max Width x 25% of Max 

Height 
Web 
Broadband 

Spherical Panorama 4000x2000 

 Cubic Panorama 7200x1200 
 Cylindrical Panorama 50% of Max Width x 50% of Max 

Height 
CD Spherical Panorama 6000x3000 

 Cubic Panorama 9600x1600 
 Cylindrical Panorama 75% of Max Width x 75% of Max 

Height 
Print Spherical Panorama 8000x4000 

 Cubic Panorama 12000x2000 
 Cylindrical Panorama 100% of Max Width x 100% of 

Max Height 
Custom You may set width and height without limitation, as long as 

computer supports. 16000*8000 or bigger. If bigger than 
16000*8000, preview, publish are not supported, you could save 
it and view it in other software. 
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Basic Steps before Stitching 

 

 
 

General Steps Before Stitching 
1. In Image Show and Operation Area, under Source Images Tab, select, delete and 
rearrange the source images for a panorama. 

 
 
Refer to  Image Show and Operation Area section in this tutorial for the detailed 
operation. 

 
2. After loading the source images, the camera and lens data of the images will be 
read and displayed in the Image Type panel. If the data can't be found in the image 
during reading the info about EXIF data, then please select an image type by 
yourself. 

 
Refer to  Image Type section for the detailed operation. 
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3. In Panoramic Type panel, set the type of panoramic image. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Refer to Panorama Type for the detailed operation. 
 
4. In Advanced Settings, select a blender between PWBlend and SmartBlend 
which will be used for blending. 

 
 
Refer to Advanced Settings for the detailed info. 
 
 
 
 

Special Steps Before Stitching: 
 
If the source images are fisheye images, you also need to set fisheye image 
enclosing: 
This is an important step to get the high quality panorama for fisheye images. This 
function is only applicable to drum and full circular images. 



41 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Refer to Set Fisheye Image Enclosing for the basic steps. 
 

 
 
 
 
 
 

Stitch 

 

 
 
After making settings for the loaded images, choose Panorama>Stitch, 
Panorama>Stitch with Former Parameters or press directly to stitch a panorama 
automatically. If the matching point pairs are not enough, inserting matching points 
is necessary. 

 
Insert and Edit Matching Points 
How to Stitch with Parameters 
 
 
Insert and edit Matching Points 
 
What are matching points? 
Matching points are a pair of points in the overlap area of two adjacent fisheye 
images. Inserting matching points is to search out several pairs of the same points 
on two neighbor fisheye images, and each pair of points will superpose after 
stitching. 

 
When should I insert matching points? 
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In case it is difficult for Panoweaver to search out the matching points automatically, 
it will remind you to insert matching points manually. For example, the overlap area 
of two images is a white wall, which has no obvious similar parts, which is difficult 
for Panoweaver to locate matching points. 

 
If your images are already loaded, but you want Panoweaver to stitch the images 
more accurately, you may insert matching points. You must insert at least 3 pairs of 
matching points manually, and then stitch the panorama. 

 
Basic steps to insert matching points: 

1.  Click to enter Matching Points Editing View under Source Images Tab. 
2.  The Matching Points Editing Area consists of two image panels to show two 

neighbor images at the same time. Figure tags on the top of both panels 
represent the orders of images. 

3.  In two neighbor images, each pair of matching points has the same color and 
tag number. When Panoweaver stops stitching to remind you to add 
matching points, matching points in these images become green, and the 
mismatching points in these images become red, other points you add are in 
other colors. The location of each pair of points is shown as coordinates (x, y) 
and recorded in matching points list in Matching Points Panel. 

4.  When the cursor moves to a certain part of the image, that part will be 
magnified, then you can view the image clearly and add matching points 
easily. Click on the image to insert a matching point, and then cursor will 
relocate its corresponding point on the other image. Auto leaping may not be 
very accurate, so you need to adjust it manually. If you want to insert 

matching points manually without auto stitch, click at the bottom of the 
editing area to cancel auto leap. 

5.  There must be at least 3 pairs of matching points in each pair of images. 
These 3 pairs of matching points should not be too near. It will get the best 
result if they are in top, middle and bottom of the image separately. After 

inserting matching points, click or to stitch. 

 
 
 
 
Select Matching Points 
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•  Method 1: Click in left image, and corresponding tab on the right image 
will be also selected. Selected tabs are in editable status. 

•  Method 2: Click one line in Matching Points list. Selected line will become 
dark, and corresponding matching points are in editable status. 

 
Move Matching Points 
The pair of points will not move at the same time. 

•  Method 1: Click on the image, hold down left mouse button and drag it. 
•  Method 2: Edit the coordinates’ value in matching points list within Matching 

Points panel. 

•  Method 3: Click on the image, press arrow “  ” key on 
keyboard to move 5 pix; type Ctrl + “ ” to move 1 pix at a time. 

 
Delete Matching Points 
Matching points exist in pair and will be deleted in pair. 

•  Method 1: click in one image and its corresponding matching point in the 

other image will be selected automatically. Click in Matching Points Panel 
or use Delete key. 

•  Method 2: Click a line (represents a pair of matching points) in matching 

points editing list, and then color of this line became darker. Please click to 
delete matching points. 

 
 

Tip: Zoom out two images to get the rough overlap locations and insert several 
pairs of matching points. Then zoom in two images, click one line in the list of 
Matching Points to select a pair of matching points. Finally the selected pair of 
matching points will show in view port automatically and you are able to locate the 
matching points accurately. 

 
 
 
Stitch with Parameters 
Save Stitching Parameters 
You may save the parameters if satisfied with the stitched image. And you will save 
much time by importing saved parameters directly when you stitch images shot 
with the same equipment and settings. 

 
Steps: Choose Panorama>Save Stitching Parameter or use shortcut Ctrl + W, enter 
a name in the pop-up window, for instance, you may name parameters as the type 
of fisheye image, and then click Save button. 

 
 
Stitch with Former Parameters 
Parameters of images shot with the same equipment and settings are the same. As 
a result, you may save satisfied parameters and apply them to the images shot with 
the same equipment and settings. After importing fisheye images, choose 
Panorama>Stitch with Former Parameters to stitch. 
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Manage Stitching Parameters 
You may also choose Panorama>Manage Stitching Parameters in menu bar to 
manage saved stitching parameters. 

 
 

 Import: You may import external parameters, for example, parameters 
sent by others, into Panoweaver. Click Import button, or click the right 
mouse button to select Import. 

 Export: Select a parameter, and then right click or click Export button. You 
may also export and save parameters to local hard disk, and send them to 
others. 

 Delete: Select a parameter, and then right click or click Delete button. 
 Rename: Select a parameter, and then right click or click Rename button. 
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Edit Panoramic Images 

 

 
 

How to Remove Tripod 

 

 
 
FOV of fisheye lens is so wide that tripod is usually captured in the images, which 
may destroy the perfection of your images. You may take a nadir image (90° down 
view picture) to cover the tripod, or remove tripod from the panoramic image by 
some image editing software. 

 
 
Add Logo 
1. Open Ceiling/Floor panel. 
2. Select Floor from the drop down list. 
3. Click or double click in logo show area to import your image. You may enter a 
number (0~90), or click the arrow at the right side of the figure to adjust the size of 
logo. Please preview it in panoramic image show area. 

4. Click or double click in logo show area to remove logo. 

 

Tip: 
 If you stitch drum or full frame without ceiling, there will be seams in the top 

(sky) area. You may add top (ceiling) to cover it. The method is the same as 
adjustment of bottom. 

 If you want to apply parameters of top/bottom used last time, please set it in 
Tools>Advanced Settings. For details, please refer to  Advanced Settings. 

 
 
Use Other Image Editing Software to Retouch 
If you don’t want to add a logo to cover the tripod, you may also remove it from the 
image in this way: first, convert spherical panoramic image into cubic, or stitch 
fisheye image into cubic panoramic images directly in Panoweaver. Then save the 
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cubic panorama to your local and import it into other image editing software (for 
example, Photoshop) to remove tripod. Please refer to the following steps: 

 
1. Move the tripod out of where it stands after shooting the fisheye images. 

 
2. Use your camera with common lens to shoot a plane image of the floor where you 
put tripod: 

 
 
3. Get a cubic panoramic image: Use Panoweaver to stitch fisheye image into cubic 
panoramic image directly. Or stitch a spherical panoramic image, then choose 
Panorama> Spherical/Cubic Conversion to convert it into cubic panoramic image. 

 
4. Save the cubic panoramic image to your local. The picture below is an example of 
cube face with tripod: 

 
5. Import both the cubic panoramic image and the image shot in Step 2 into 
Photoshop, retouch the plane image and make it exactly cover the tripod. The 
following picture is the result: 

 
 
6. Save panoramic image and re-import it into Panoweaver to publish. 
 
 

Remove Tripod by Shooting Additional Shots 
1. Shoot additional ceiling/floor shots without tripod to replace the original shots.  
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2. When shooting ceiling/floor, shooting position should be almost the same with 
the original position. The degree difference between the two positions should be 
limited in 20 degree. 
3. Then click Stitch to get a panoramic image with tripod removed. 
 
 
 
 

Add Hotspot to Panorama 

In Panoweaver 7, you could add hotspots to a panoramic image. Steps are as below: 
1. Click on "Set Hotspots" button  in Flat View under Panoramic Image tab. 
2. Add hotspots to the panoramic image in the popup Hotspot Settings window. 

 
  
3. And make settings to hotspots in the properties panel, such as adding a certain 
action like "Link to URL". 
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Edit Hotspot 

Click Set Hotspots button  in Flat View under Panoramic Image tab to go to the 
hotspot settings window. 

 

Add Hotspot 

1. Click on Add Hotspot 
2. Then move your mouse on the panoramic image and press left mouse button to 
add a hotspot. And the properties panel will display its properties and action. 

  

Delete Hotspot 

Method 1: Select a hotspot, and click Delete Hospot.  
Method 2: Select a hotspot, and press Delete button on your keyboard. 

  

Select Hotspot 

Click a hotspot on a panoramic image or Click the hotspot name in Hotspot List. 
Selecting multiple hotspots is supported. 

  

Move Hotspot 

 After selecting one or more hotspots, hold the left mouse key and drag. 
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 Use arrow keys  to move the selected hotspots. 

 Move a single hotspot by changing the X,Y coordinates of it in the properties 
panel of the hotspot. 

  

Set Hotspot Properties 

 

Component: Display hotspot name. 
W/H: To set hotspot area. 
X/Y: Set x,y coordinates of hotspot. 
Icon: Set icon for hotspot. Two types: Text and images (hotspot image by default 
or hotspot images located at [InstallDir] \Libraries\Image\Hotspot).  

Text: If you want to get a text hotspot or a text-image hotspot, please type text 
here and click to set font, size, align, etc for the text. 
Hint: You can also set font, size and color for the hint text. Click to set hint 
properties.  

 
Link to None: To set hotspot action. None represents the hotspot doesn't link to 
anything. 
Link to Popup Image: You can add Pop up Image action to Hotspot. After this 
action is added to hotspot, when clicking on the hotspot, the relative image will be 
shown in a popup window right beside the mouse. The setting window is shown as 
below:
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Link to URL: To link to a certain URL. Make setting as following: 

 

Note: When multiple hotspots are selected, in the properties panel, W/H, Icon, 
Text and Hint are editable, while other options are not editable. 

Note: The edited hotspots can only display in hotspot panel, which don't display 
in panoramic image area or under preview mode. 
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Preview Panorama 

You may preview panoramic image before publishing it if you have stitched it. You 
may retouch it in time if you are unhappy with the results. Select File>Preview or 

click on toolbar to preview a stitched panorama. 
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Save Panoramic Image 

Choose File>Save Panoramic Image or click on toolbar, select proper format and 
enter file name, click Save button. You may retouch or print saved panoramic 
image, or make it into a multiple-scene virtual tour. 

 
You may save the panoramic image as the following formats: 
Windows Bitmap (*. bmp), JPEG Image Format (*. jpeg; *. jpg), Photoshop (*. psd), 
Portable Network Graphics (*. png), Targa Files (*. tga), Tiff Image Format (*. tiff; 
*. tif). 

Note: Most of the above formats belong to 8-bit image. Panoweaver can also 
save 16-bit for Tiff image and HDR images. 

Adjust JPEG quality 
If the format you select is JPEG, click Quality button to adjust image quality in the 
pop-up window. 

 
Move the slider, or use arrow key to adjust JPEG quality. You may preview the result 
in Compressed Image area. JPEG quality is closely related with file size, so please 
select a proper value balancing file size and image quality (85 is recommended for 
common users). 
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Convert Cube Faces 
If the current panorama is cubic one, you could tick this option to convert it into 6 
images with ratio 1:1. See below: 

 
 
 
 

Retouch Image 

 

 
 
If you are unhappy with stitched panoramic image, please save it first and then 
import it into Photoshop or other image editing software to retouch, finally 
re-import it into Panoweaver to publish. Take Photoshop as an example. 

 
1. Save panoramic image as PSD format. 

 
 
2. Use Photoshop to open and retouch it. 
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3. Re-import retouched panoramic image into Panoweaver and publish it. Choose 

File>Import Panoramic Image or click on toolbar. 
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Print Panoramic Image 

 

 
 
Panoweaver does not support Print function, so you have to print it in other image 
editing software. 

 
1. Save panoramic image to hard disc. 

2. Use Photoshop, Firework, ACDSee or other similar software to open it. Choose 
File>Print. 

 
 
 
 
 

Make Virtual Tour with Tourweaver 

For most users, single panoramic image created by Panoweaver is far from meeting 
demand. What they want is a virtual tour which contains multiple panoramic images, 
interactive maps, word description, etc. Easypano Tourweaver is the best choice. 

 
For details about Tourweaver, please visit: 
http://www.easypano.com/how-to-make-a-virtual-tour.html 

 
Download Trial Version at: 
http://www.easypano.com/free-trial.html 

 
Click this image to view virtual tours made with Tourweaver using the panoramic 
images stitched in Panoweaver as source images. 

http://www.easypano.com/how-to-make-a-virtual-tour.html
http://www.easypano.com/free-trial.html
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Publish Panorama 

 

 
 

After stitching, choose File> Publish Panorama or click on toolbar to publish 
Panorama. 

 
Basic Steps: 

1.  Select publishing  format. 
2.  Enter file name. 
3.  Select output path. 
4.  Set general publishing parameters in  General. 
5.  Set individual parameter for each publishing type. 
6.  Click Publish. 

 

 
 

Publishing Format 
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Type: 
You may publish as Shockwave Flash (.swf), Flash VR, Easypano Virtual Tour Player 
(Java Applet), QuickTime VR, and HTML5 
 
File Name: 
Name the published file, for example pano1 (Please don’t use space in the file 
name). 

 
Output Path: 
Specify output path for the file you want to publish, for example, C:\Program 
Files\Easypano\Panoweaver 7.20\output\; System will establish a folder with the 
same name as the file, so output path becomes: C:\Program 
Files\Easypano\Panoweaver 7.20\output\pano1\. System for your convenience will 
establish sub folders "_swf", "_flash", "_applet", "_qtvr" and "_Html5" under this 
folder, so files will be saved separately in the sub folders. 
 

General Properties 



58 

Purpose Recommended Size of Viewer 
Web Dialup 400×300 
Web Broadband 640×480 
CD 800×600 
Print 1024×768 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Options: 

 Open output folder after published. 
 Generate files for autorun CD (autorun.inf): If this option is selected, 

Panoweaver will generate an autorun.inf file for autorun CD. 
 
Compression Quality: 

Click Quality button to adjust image compression quality and display compressed 
size of file in the pop-up window. Refer to  Adjust JPEG quality. 

 
Thumbnail: 

Thumbnail of panoramic image in html page. Customize the size of thumbnail in 
index.html in the published files. The default size of the thumbnail is 160x80 pix. 

 
Viewer Size: 

Set the size of viewer. 
Recommended: Panoweaver will calculate a recommended size of viewer in 
accordance with the size of panoramic image. Please refer to the following table: 
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Custom Panoweaver calculates the size of 
viewer according to the size defined by 
users. 

Custom: User defines the size of viewer by himself. 
 
Viewer Parameters: 

 
Set the initial, max and min values of Pan, Tilt, FOV of panorama when playing. 
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Flash VR 

 

 
 

 
 
Click the hyper text Settings and a dialog box will pop up. You are able to customize 
Loading Window. 

 
Loading Window 
Background Color: 
Set the background color of loading window. 

 
Preloading Image: 
It allows users to modify or set preloading image. To set the style of preloading 
image among None, Standard and Custom. 
 Select None. It indicates there's no preloading image in Loading Window. 
 Select Standard. The default preloading image will appear in Loading Window. 
 Select Custom. You could customize a preloading image. Click to select a file you 

like (supported formats: .swf, .jpg, .bmp, .gif). 
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Control Button: To set toolbox, buttons and their position on scene viewer. Click 
the hyper text Settings and a dialog box will pop up. 

 
The components like Progress bar, Toolbar, Print, Email To, Show Help or Play 
Sound can be added to scene viewer. 
Add Components to Scene Viewer 
1. Click a certain component from Toolbox. 
2. Click the blank part of Main Window to place the component. 
Note: Each component can only be added once. 
  
Delete Component 

Select a component in scene viewer, and then click Delete.  
 

Set Properties for Components 
Set Properties for Progress Bar 

To set progress bar style. 
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To set the style of the progress bar  

among Standard, Custom (only for pro and batch edition) 
among None, Standard in Standard edition (None indicates progress bar and 
percentage loaded are not displayed; Standard indicates displaying a standard bar 
and percentage loaded; Custom: You could import a progress bar with .swf format.) 
Display Percentage Loaded: If selected, the progress bar will display the loading 

percentage, if not selected, the loading percentage won't be displayed.  
Width/Height represents width and height of progress bar. 
Bar Color represents the color of progress bar. 
Container Color represents the color of container. 

 
 
Set Properties for Toolbar 

To set its position and import a toolbar style. 
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Set Properties for Print 

To set its position, image and hint. 

 
X/Y: To set Print button position or just drag the button in Scene Viewer to adjust 
its position.  
Image: You can also customize the Print button appearance by importing three 
images for the three states of the button. Each button possesses three states 
including normal state, over state and down state. When you select xx_1.jpg as the 
image for normal state, the program will search xx_2.jpg and xx_3.jpg in the same 
folder automatically; and add them as the images of over state and down state. 
Therefore you may use the same prename for the three state images like xx_1.jpg, 
xx_2.jpg and xx_3.jpg to save your time when importing them. 
Hint: If you want some hints to appear when putting mouse over the button, you 
can input the tips here; and you can also customize font, size, color etc.  
 
 
Set Properties for Show Help 

To set info image for panorama. 
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As to settings for X/Y, Hint, Image, please refer to Print properties setting. 
Source File: To import an image file. 
 
 
Set Properties for Play Sound 

 
As to X/Y, Hint settings, please refer to Print properties setting. 
Image: 
Type of Play Sound button is toggle button, so two sets of images are required. 
When Play is selected, to set images and hint for Play state. 
When Pause is selected, to set appearance for Pause state. Refer to Print button for 
image setting. 
 
 
Background Sound: 
Add background sound for the panorama. If Loop is selected, the sound will be 
always repeated.  
Autoplay: to set whether to play sound initially. 
  
Context Menu Website Link: To set URL link on the right click context menu of 
player after published. 

 
 
Resized to 50% for non-fullscreen mode: 
If selected, the scene viewer will play the panoramic image in reduced size (50% of 
original panoramic image) in the normal mode compared with the full screen mode. 
If not selected, the panoramic image played in the scene viewer is of original size 
both in normal mode and full screen mode. 
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Slice Display: 
Refer to Slice Display in Easypano Virtual Tour Player section. 
 
Initial Auto Rotation: 
Refer to  Initial Auto Rotation in Easypano Virtual Tour Player section. 
 
Rotation Speed: 
You may set the rotation speed of panoramic image. Default speed is 20 frames/ 
second. 

 
 
Click the thumbnail below to view the Flash panorama. 
 
 
 
 
 
 
 
 

Note: Please download and install the latest version of  Flash 9 player if you 
cannot view the panorama. 

http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash&promoid=BIOW
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Standalone SWF 

 
As to the settings, please refer to Flash VR 
 
 

Easypano Virtual Tour Player 
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Click the hyper text Settings and a dialog box will pop up. You are able to customize 
Loading Window. 

 
Loading Window: 
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Background Color: 
Set the background color of loading window. 

 
Loading Image: 
It allows users to modify or set loading image. To set the style of loading image 
among None, Standard and Custom. 
 Select None. It indicates there's no loading image in Loading Window. 
 Select Standard. The default loading image will appear in Loading Window. 
 Select Custom. You could customize a loading image. Click to select a file you 

like (supported formats: .jpg, .bmp, .gif). 
 
Progress Bar: 
 To set the style of the progress bar among None, Standard (None indicates 

progress bar isn't displayed; Standard indicates displaying a standard bar.) 
 Width/Height represents width and height of progress bar. 
 X, Y indicates the position of progress bar, relative to the top left corner of 

loading window. 
 Bar Color represents the color of progress bar. 
 Container Color represents the color of container. 

 
Initial Full Screen: 
If this option is selected, the viewer will be displayed at full screen mode when it is 
loaded. If not selected, viewer will be displayed in accordance with the size set in 
general properties. 

 
Slice Display: 
Panoweaver 7.20 provides slice display mode. There will be a transition effect after 
panorama was loaded but has not been played yet. There are 3 types: 
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Fill with Color: Users specify a type of color to fill panorama. Click to select 
color. 

      Gray: Zoom in the thumbnail of initial Gray-scale image to fill panorama. 
      Blur: Zoom in the thumbnail of initial image to fill panorama. 

 
Initial Auto Rotation: 
If this item is selected, panoramic images will be played automatically at the speed 
you set. You may set Direction for it and default direction is Right. If this item is not 
selected, initially panoramic image will be in still status. 

 
Rotation Speed: 
You may set the rotation speed of panoramic image. Default speed is 20 frames/s. 
 
 
 
 
 

Quick Time VR 

 
 
Full Screen QTVR: 
To play your QTVR panorama in full screen on start, please tick the check box of Full 
Screen QTVR. 
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Upload to Website 

 

 
 
There are steps to upload panorama to website: 
Use website editing tools like Dreamweaver to establish a local website with the 
same structure of your website server (if you already have site, please skip this 
step). 
Publish panorama into a specified local folder of this site. 
Upload the published files to the relative destination on your server. 
If your website is maintained by others, you have to send the files to them to upload 
instead. 

 
Easypano Virtual Tour Player 
After you publish panorama as Easypano Virtual Tour Player format, you will find the 
following files in the published folder: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
How to embed panorama into webpage: 
Use webpage editing software (for example, Dreamweaver) to open the webpage 
which you want to embed the panorama, for example, home.html. 
Double click to open the published html file index.html. In this html file you will see 
the steps. 
Copy the codes generated in the text area of index.html (see image below), paste 
them to webpage home.html, and save it to the same folder with all published files. 
Finally, use FTP tool (for example, CuteFTP) to upload all files to website server. 
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QuickTime VR 
Same as Easypano Virtual Tour Player, after you publish panorama as QuickTime VR 
format, you will find the following files in the published folder: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Steps to embed the QTVR panorama into webpage 
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Flash VR 
Panoweaver 7.20 enables you to publish panorama as Flash VR, you will find the 
following files in the published folder: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Steps to embed the Flash VR into webpage 
 
 
Standalone SWF 
Panoweaver 7.20 enables you to publish panorama as .swf, use it as other swf files. 
 
 
 
 

Project 

You may save unfinished panoramic image as a .pw file (a project) before quitting 
Panoweaver. In this way, you can just open the project and resume your work 
instead of importing fisheye images or adjusting parameters again once you don’t 
finish the work. This function will save much time and energy for you. 

 
Save Project 

1. Choose File>Save Project or click on toolbar; 
2. Enter output path and file name in the pop-up dialog box; 
3. Click OK to save it as .pw file. 

 
Import Project 
There are three methods to open a project: 

 Select at File>Open Project, or click on toolbar; 
 Drag .pw file into Panoweaver Editing area, or drag it onto Shortcut of 

Panoweaver. 
 Double click icon of .pw file in the folder, as shown below: 
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Advanced Settings 

Select Tools>Advanced Settings, and Advanced Settings dialog box will pop up. You 
are able to set general parameters and apply Smartblend plugin. 

 
 

Initial Value of Fisheye Image Enclosing: 
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If you select Auto Calculated, Panoweaver will calculate Fisheye Image Enclosing 
automatically; if you select Last Used, then Panoweaver uses values used last time 
as initial value. 

 
Ceiling/Floor Size: 
If Last Used is selected, Panoweaver will use the value you set last time. If the 
checkbox isn't ticked, the default value is 30. 

 
Blender: 
Blender determines which application will be used for blending and attempts to 
create a seamless overlap between images. Panoweaver includes its own 
blender-PWBlend, which is sufficient for nearly every panorama. Additionally, the 
other blending plugin is supported as well: SmartBlend. 

 
Set SmartBlend plugin in the popup window by clicking on button "Browse" . You 
could use SmartBlend as a plugin for stitching in this section. For more info 
regarding the blending plugin, please visit 
http://www.easypano.com/showkb_285.html. 

 
Tip: 

 
 
 
 
 

Get HDR Image 

What is HDR Image? 
HDR is abbreviation for High Dynamic Range. For a scene, dynamic range refers to 
ratio between the brightest and darkest parts of the scene. The Dynamic Range of 
real-world scenes can be quite high - ratios of 100,000:1 are common in the natural 
world. An HDR image stores pixel values that span the whole tonal range of 
real-world scenes. 
Dynamic range of JPEG format image won’t exceed 255:1, so it is considered as LDR 
(Low Dynamic Range). Similarly, dynamic range of CRT monitor won’t exceed 100:1. 
While HDR image (image of 32bit/color channel) shows the dynamic range of real 
world (natural dynamic range is generally considered to be 100,000:1; the dynamic 
range human eyes can identify is around 100,000:1), which is much higher than 
that of standard display equipment and images shot with common camera. As a 
result, HDR image cannot be displayed with this equipment. So from broad sense, 
image with dynamic range of higher than 255:1 (8 bit per color channel) is regarded 
as HDR image. 

 
 
 
Image bit and dynamic range 
There are two methods to show image bit. One is bits/color channel; the other is 
bits/pixel. For RGB images, each pixel contains 3 color channels - R, G, B. Image bit 
has the following relation with dynamic range (lightness ratio): 

 

Type of digital Bit depth Bit depth Maximum Note 

http://www.easypano.com/showkb_285.html
http://www.easypano.com/showkb_285.html
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support per color 

channel 
per pixel dynamic 

Range 
 

JPEG or 8-bit TIFF 8 24 255:1 256=28 
12-bit CCD 12 36 4,096:1  
14-bit CCD 14 42 16,384:1  
16-bit TIFF 16 48 65,536:1 "Real" maximum 

limited by dynamic 
range of capturing 
device 

HDR image (e.g. 
Radiance RGBE 
format) 

32 96 infinite "Real" maximum 
limited by the 
captured dynamic 
range 

 
 
 
Why to use HDR Image 
 
When you take a picture inside of a room, the bright windows always get dazzling 
white since the camera and display are simply incapable of displaying the 
luminosities in the real world. While HDR images captures wider color range, which 
helps photographers get better images, solving the over exposure and under 
exposure problem in photography, especially digital photography. For some users, 
they can save the 32 bit HDR as well and make some further editing. 

 
Let's see the traditional troublesome way to solve the over/ under exposure 
problem first. 
1. Shoot images to create a panorama. 

 
2. Take an extra image in the direction of the over exposure window at an 
appropriate EV which allows users to see the window through clearly. 
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3. Use Photoshop to take out the window area and make a mend in the panoramic 
image got in 1st step. After all the heavy work, then you will get a panoramic image 
of good result. See below. 

 
You have to spend hours for every panoramic image with the method above. While 
with HDR, you can get a good result image without troublesome work. Panoweaver 
6.00 automatically makes an HDR image, which stores wider luminosity range than 
that can be displayed. You can simply adjust on the HDR image in the software and 
get a perfect image quickly. Below is an image converted directly from HDR without 
any other editing work. Please refer to How to Get HDR Image for details of 
generating HDR with Panoweaver 7.20. 
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How to get HDR panoramic image with Panoweaver 7.20? 
There are two methods. One is to import Camera Raw file and to stitch it into 16 bit 
panoramic image. The other is to get HDR image from bracket exposure, that is, to 
shoot several groups of images of the same object with different exposure value, 
batch stitch them and then combine them to get HDR image. 

 
 
 
 

Get HDR Image from Camera Raw File 

 

 
 
About Camera Raw 
 
In addition to JPEG, TIFF, digital camera can also save picture as Camera Raw file 
Camera Raw has not been processed in any form and it has to be converted into 
common format, for instance, TIFF, to edit. Camera Raw contains the highest 
quality information when CCD captures picture. Panoweaver 7.20 allows users to 
import Camera Raw to get high quality panoramic image. 

 
Tip: 

 
Steps: 

1. Choose File>New Project or click on toolbar, set file format as Camera Raw in 
the Open Images window. Click Open, and then Camera Raw window will appear. 
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2. Adjust Exposure Compensation and Gamma to a satisfactory value, select 
“16bits/channel” in Image Depth, and then click OK. 

 

3. Choose Panorama>Stitch or click on toolbar to stitch fisheye image. 
 
4. Click File>Save Panoramic Image to save it as 16-bit tiff format. 

 
5. Panoweaver 7.20 does not support publishing of 16 bit images. You must convert 
it into 8 bit image before publishing. HDR to LDR option will assist you to convert the 
image. Choose Image>HDR to LDR, the program will convert it automatically. 

Note: 8 bit images show “24b” in status bar, and 16 bit images show 48b. 

 
 
 
 
 

Get HDR Image from Bracket Exposure 

Bracket Exposure 
When camera's auto metering system cannot calculate Exposure Value (EV) 
correctly, you may shoot several images (3 images are recommended). Set a 
"camera estimated" correct exposure value 0 EV and take the first image. Then take 
a second and third image at +2EV (over exposed) and -2EV (underexposed). From 
these images you may choose one with the best exposure effect. Panoweaver 7.20 



79 

just takes advantage of the bracket exposure. At each direction, you may shoot 
several images with predefined exposure values, and then place images with the 
same exposure value into the same group to stitch them; finally, you may combine 
the stitched panoramic images to create HDR images. 

 
Tip: 

Basic Steps with Panoweaver Professional Edition 
Basic Steps with Panoweaver Batch Edition 
How to combine the generated panoramic images into an HDR Image 
 
 
 
Basic Steps with Panoweaver Professional Edition 
1. Shoot several groups of image (e.g. three groups) with three stops. Import each 
group of images into Panoweaver 7.20 pro and stitch to get three panoramic 
images. 

2. Access Windows Start menu: Start>Programs>Easypano>Panoweaver 7.20 
Professional Edition>Create HDR Image, then the Create HDR Image window will 
pop up. 

 
3. Import the three panoramic images into Create HDR Image window and click 

to create an HDR image. Refer to  How to combine the generated panoramic  
images into an HDR Image for the details. 

 
 
 
 

Basic Steps with Panoweaver Batch Edition: 
1. Access windows Start menu: Start>Programs>Easypano>Panoweaver 7.20 
Batch Edition>Batch Processing. The Batch Processing window will appear. 

2. Select Batch Stitch as the batch processing mode. Click to import all sets of 
bracket exposure images. 

Note: Please make sure the image format is JPEG; otherwise you cannot use 
bracket exposure. 
3. Make some adjustments in the Settings window (Check the Bracket Exposure box 
and select the corresponding stops). 
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4. Click Begin Processing button to batch stitch panoramas. 

5. Click Create HDR Image button to combine the generated stitched 
panoramic images into an HDR image. 

 
 
 
 
How to combine the generated panoramic images into an 
HDR Image 
After stitching each group of images, click on Create HDR Image, a window will pop 
up. Before combining, you need to check if EXIF information of each panoramic 
image is complete and to specify the camera response curve. 
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A: Source Images: select the images first and check the EXIF info before combining. 
B: Camera Response Curve: specify the camera response curve for generating an 
HDR image. 
C: Result Image: edit or save the generated HDR image. 

 
A: Source Images 
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 Select a file in File name to preview the image at the left side. The selected 
images will be combined into an HDR image. 

 You may view and modify aperture, shutter and exposure compensation 
value in Create HDRI window. 

How to Edit EXIF information? 
Click table cell and the figure will become editable. You may enter a value directly or 
click the arrow of the drop down list to select one. 

Note: File name (image name) cannot be edited. Images in the same group 
should have the same parameters. 

 
 
 
B: Camera Response Curve 
You have to select or generate one camera response curve before stitching HDR 
image. 

 
Tip: 

 If you select Use existing camera response curve, please use the 
specified value in drop down list to stitch HDR image. 

 If you select Calculate camera response curve, the system will calculate 
curve value before creating HDR image. 

 You may save this curve value by selecting Save Curve and specify its name in 
Curve Name. Once the curve value is saved, next time you may use it directly 
from the drop down list below Use existing camera response curve. The 
curver value can be saved to a file with extension .crv. 

 
C: Result Image 

 After the process finishes, thumbnail of the HDR image will appear under the 
Result Image tag, with ratio 2:1. 

 Switch between 32bit (HDRI) and 8bit (LDRI) under Bit Depth. 
 Adjust Exposure and Gamma by moving sliders after tone mapping. 

 You may save the HDR to local by clicking Save icon. Select 32bit (HDRI) from 

the Combobox, then click Save. You may also select 8bit (LDRI) option to 

convert HDRI to LDRI then save it. A dialog will pop up after clicking Save, 
please refer to  Save Panoramic Image for the details. 

 
Tip: To combine panoramic images of different exposure value together to 

create an HDR image, access Start>Programs>Easypano>Panoweaver 7 Batch 
Edition>Create HDR Image or Start>Programs>Easypano>Panoweaver 7 
Professional Edition>Create HDR Image to open the Create HDR Image window, 

then load the images directly by clicking New icon, finally click to create an 
HDR image. 

 
 
 
 
 

Batch Processing [Panoweaver Batch only] 

Batch Processing includes  Batch Stitch, Batch Publish and Batch Spherical/Cubic  
Conversion. 
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Work Space 

Working area of batch processing includes: Menu Bar, Toolbar, Image List, Height 
Adjustor, Settings Display Area. 

 
 
A-Menu Bar: Includes File, Edit, Help. 
 

Item Feature Description Shortcut 
New Start a new project Ctrl +N 
Import Images Import Images Ctrl + I 

File 

Exit Exit Program Ctrl + Q 
Begin Processing/Cancel 
Processing 

Begin batch 
processing or cancel 
batch processing 

- 

Settings Settings - 

Edit 

Create HDR Image Create HDR Image - 
Help Topics Opens the help file of 

Panoweaver 
F1 Help 

About Easypano Panoweaver Copyright 
information of 
Panoweaver 

- 

 
Details: 

 Select File>New, a dialog box will pop up as below: 
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Select a batch mode and click OK before batch processing begins. Then setting 
items relevant to the selected batch mode will display in Settings Display Area. 

 
 Select File>Import Images, the imported images will be divided into multiple 

groups (Under Batch Stitch mode, groups are divided according to 
Image>Number, under the other two modes, one image is regarded as one 
group). 

 
 Select Edit>Settings. 
1. Click on Batch Stitch tab: 

 
Batch Stitch: 
Batch stitching is only available in Panoweaver Batch version. If you want to stitch 
several groups of images of the same type quickly, choose Start> Program> 
Easypano> Panoweaver 7.20 Batch Edition> Batch Processing to select Batch Stitch, 
make settings, then Panoweaver will complete all work for you automatically 
according to your settings. 

 

Note: The maximum quantity of batch stitching is 100 sets of images. 
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As to the settings made to  Image Type, Panorama Type, Stitch, Blender, 
Ceiling/Floor, Output Format, File Name and Output Path, please refer to Stitch 
Panoramic Image. Make your own settings if necessary. 

 
Panorama Size: 
Web Dialup——1400*700 pixels by default 
Web Broadband——4000*2000 by default 
CD——6000*3000 pixels by default Print—
—8000*4000 by default 
Custom——It is allowed to customize the height. 

 
File Name: How to name a file? 

 
 
 
 

Editable Text 001, 002, 
 

pano1 (Every time you 
start a new project, the end 
number will automatically 
+1 as the default value of 
the item) 

003... 

 
 
 
2. Click on Batch Publish tab: 

 
Batch Publish: 
If the ratio of width to height is 2:1/6:1/1:6, the imported images can be published 
to three output formats. 
If the ratio is 1:1, the imported images can't be published to Flash or QTVR formats. 
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If the ratio is different from all the above ones, the imported images will be regarded 
as cylindrical panorama, and can't be published to QTVR format. 

 
As to the settings made to Ceiling/Floor, Output Format, File Name and Output Path, 
please refer to  Stitch Panoramic Image. 

 
 
 

3. Click on Batch Spherical/Cubic Conversion tab: 

 
Batch Spherical/Cubic Conversion: 

If the ratio of the imported images is 2:1, they will be regarded as spherical 
panoramas and be converted into cubic ones. 
If the ratio of the imported images is 6:1 or 1:6, they will be regarded as cubic 
panoramas and be converted into spherical ones. 

Note: The format of the output images is the same as that of imported images. 
 
 
 

B-Toolbar: To display the menus which are frequently used. 

 
 

Icon Tool Tip Feature Description 

 
New File > New 

 Import Images File > Import images 

  
Begin Processing/ 
Cancel Processing 

Edit > Begin Processing/ 
Cancel Processing 

 
Create HDR Image Edit > Create HDR Image
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C-Image List: Includes: Image List, Preview Area. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
1. To indicate the item that is being processed. 
2. To display the output file name. 
3. To display the path of the imported image. 
4. Three processing status: Finished, Processing or Waiting. 
5. Two processing result: Failed or Successful. 

 
D-Height Adjustor: To adjust the height of Image List Area and Settings Display 
Area. 
E-Settings Display Area: To display the items you have set. 

 
 
 
 

Basic Steps of Batch Processing [Panoweaver Batch only]
 

 

 
 
Basic Steps: 
 
1. Select all the images and right click to choose Panoweaver Batch>Batch Stitch 
with Panoweaver. 

 

 
 
 
 
 
 
2. A batch processing window will pop up. 
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3. Click New button , a New dialog box will pop up. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
4. Select a processing mode, and click OK. At the bottom of the interface, the 
parameters items will display and a dialog box will appear to remind you. If you 
want to change the displayed parameters, click on Modify Settings. 
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5. Click on Import Images button to import images. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
6. Click Begin Processing button to start batch processing. 
7. Click Modify Settings after batch stitch completes, make settings under batch 
publish to batch publish the generated panoramic images. 
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Tip: 
 Batch processing via right click: 

1. Select multiple images. 
2. Right click on images. 
3. Select Batch Stitch/Publish/S/C Conversion with Panoweaver in the popup right 
click menu. 

 Under Batch Stitch mode, after processing completes, click Create HDR Image 

button , import the generated panoramic images in the popup Create HDR 
interface to create HDR image. 

 
 
 
 

Batch Stitching[Panoweaver Batch only] 

 
 
 
Batch stitching can be used to stitch several projects in batch. The projects need to 
be prepared 
in Panoweaver and must contain an output filename. On Windows, there is also a 
shortcut to the batch stitching in the Panoweaver Start menu folder. 

 
Batch stitching is only available in Panoweaver Batch Edition. If you want to stitch 
several groups of images of the same type quickly, choose Start> Program> 
Easypano> Panoweaver 7.20 Batch Edition> Batch Processing to select Batch Stitch, 
make settings, then Panoweaver will complete all work for you automatically 
according to your settings. 

 

Note: The maximum quantity of batch stitching is 100 sets of images. 

Basic steps of batch stitching: 
1. Import multiple images. 
2. Choose Image Type that will be used to stitch panoramas. 
3. Click Begin Processing to start batch stitching. 
4. When the stitching process is completed, click Create HDR Image if you want to 
create a HDR image. Refer to  Create HDR Image for details. 
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New: Click the button to start a new project. 

 
Begin Processing: click the button to begin processing. 

 
Cancel Processing: Click the button to cancel processing. 

 
1. To display the path of the imported images. 

 
There are two ways to import the source images for batch stitch: 
      Method1: Choose Batch Stitch in the Panoweaver Start menu, then import 

images by clicking Import in the popup window. Then the path of all the 
imported images will be listed in this section. 

Note: Only the imported images of the same path can be batch stitched. The 

supported image formats are JPG, PNG, TIFF, BMP (Only 8bits image supported). 
      Method2: Select the images first, then right click and select Panoweaver 

Batch>Batch Stitch with Panoweaver. 
 
2. To select a processing mode for stitching, and make 
settings to each mode. 

 
Tip: If the imported source images are  fisheye images including Full Circular 

Fisheye Image, Drum Fisheye Image, and Full Frame Fisheye Image, select a image 
type to create spherical or cylindrical panoramas. To convert from cubic panorama 
to spherical one or vice versa, select Batch Spherical/Cubic Conversion. 

 
Click the hypertext Modify Settings, the settings window will pop up. 
As to the settings, please refer to  Batch Stitch Settings. 

http://www.easypano.com/product-36_244.html
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3. To display the stitching result. 

 
Tip: After the batch stitching finishes, click hyper text Create HDR to get a HDR 

panoramic image with the generated panoramic images. For details about how to 
create HDR, please refer to  How to combine the generated panoramic images into 
an HDR Image. 

 
 
 
 
 
 

FAQ 
 

 

General Questions: 
 
1.How to know if my Panoweaver is the latest version? 
Choose Help>Check for Update to check online. 

2.How to report BUG to Easypano? 
Choose Help>Bug Report/Feature Request, enter it in the pop-up window. 
3.What should I know to shoot fisheye image with Ceiling/Floor? 
If you want to shoot fisheye images with Ceiling/Floor, you should shoot images in 
horizontal direction first. After shooting the last image, rotate camera up to shoot 
ceiling; then rotate down to shoot floor.  

Note: You should shoot Ceiling/Floor images at the same location of the last image 
of horizontal direction, and do not move tripod or camera. For details, please refer 
to How to Shoot Fisheye Images. 

4.How to activate Panoweaver? 
First you need to buy Panoweaver to get one license key. Enter this license key to 
activate Panoweaver at the first time you start to use it. Panoweaver will prompt 
what to do next.  

Tip: The license key is able to be used on two computers at the same time. But you 
need to transfer license key or to buy volume license if you want to use this license 
key on a third computer. 
 
5.When should I make HDR image from Raw format? When should I make 

HDR image from bracket enclosing? 
If there is moving object in the scene, Raw format will get better effect. 

If all objects in the scene are still, bracket enclosing will get better effect.  
6. I have used auto-match function when inserting matching points, why it 
is still not accurate? 
Panoweaver allows the misalignment of the location of auto-matched points as long 
as they are within certain range. If misalignment is really serious, please check: (1) 
if the two images are adjacent;(2) for Circular and Drum type, are the center of the 
circle and radius set correctly. 
 
If you encounter a problem when using Panoweaver which is not answered in this 
online help, visit the Panoweaver Support page at 
http://www.easypano.com/faq.html or http://www.easypano.com/kb.html. Here 
you'll find an up to date list of frequently asked questions and answers, and links to 
additional resources. 

 

http://www.easypano.com/how-to-shoot-panoramas.html
http://www.easypano.com/faq.html
http://www.easypano.com/kb.html
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7. Some tips used in stitching. 
If the fisheye images distortion you have shot is large, it is suggested that you 
change the FOV manually (e.g. 185 degree), and then stitch them. 

 
 
 

Panorama Photography 
 

 

Shoot Normal Images 

Panoweaver 7.20 supports normal lens, wide-angle lens and fisheye lens. It can 
handle almost every kind of image (one row or multiple rows of images), in any 
orientation. 
 

Workflow of Shooting Normal Images 
 
Shoot with pano head and tripod 
1. Set your photographic equipment in place: a tripod, a pano head and a camera. 
Attach the Pano Head to the Tripod to make sure the pano head can spin smoothly 
around the tripod axis. 
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2. Attach the Camera to the Pano Head: Assure the camera body and horizontal line 
in a right angle. Locate nodal point to keep the camera in a fixed position to avoid 
parallax error. Refer to How to locate nodal point? 
3. Calculate the rotation degree and the number of rows required for stitching and 
shoot images. 

 
Tip: To stitch a 360 degree panoramic image, the number of shots required for 

stitching varies with different cameras and lens. A calculating tool is available at 
http://www.easypano.com/Panorama-software-47_382.html. 

 
Shoot hand held 
1. Calculate the rotation degree: to calculate the rotation degree when shooting 
each shot (360/the minimum number of shots, for example, if the minimum number 
of shots after calculation is 12, then the rotation degree should be 30). 

 
Tip: If the calculation result is shooting at least 11 images, shooting 12 images 

is suggested to get a better stitching result. 
2. Hand hold a camera, keep the camera in the same spot for every shot and 
proceed in a straight line. Don’t move the camera up and down between shots to 
follow an up and down horizon. Ideally, use a tripod. 

 

Tip: 
1. To get the best result inside a building for professional use, please note: 
A tripod and a panoramic pano head are suggested while shooting. Handhold 
shooting is not suggested. As well, the nodal point should be adjusted precisely. 
2. If you want to shoot far away objects outside a building and only one row of 
pictures for stitching, handhold shooting can also be applied. 

 

Note: For the best results, take photos using the following tips: 
1. Keep the camera in the same spot for every shot. The distance between camera 
and floor should be kept unchanged. 
2. Make sure that there is some overlap from photo to photo. For example, if you are 
sweeping from left to right, locate an object in the right side of your viewfinder on 
the 1st shot. Then make sure you can see that same object on the left side of your 
viewfinder on the 2nd shot. Continue this for each shot. Ideally, you should have 
about 25%-40% of each frame overlapping the previous frame. 
3. Based on the calculated number of shots required for stitching, shooting more 
images than required is suggested. 
4. Shooting photos clockwise is suggested. 
5. Lock the camera's exposure and white balance for all shots. This will help to avoid 
substantial changes in lightness/darkness from frame to frame. If you can’t or don’t 
want to do this, and there are substantial variations in lightness from frame to frame, 
take your shots with more overlap (e.g., 50% overlap from shot to shot). This will 
minimize the amount of lightness change from any one shot to the next shot. If you 
can, also lock your white balance for all shots. 
6. Beware of objects which move between shots. Clouds move, trees sway in the 
wind, and people move around. If people and/or things are moving, take your shots 
as quickly as possible to minimize the amount of variation between frames. 
7. Don't zoom in or out between frames. 

http://www.easypano.com/Panorama-software-47_382.html
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Shoot Fisheye Images 

Main Photography Equipment 

 Digital camera (abbreviation as DC): Theoretically, both digital camera and film 
camera work with fisheye lens to shoot fisheye images. However, Digital cameras 
are much convenient since the images can be transferred to computer directly 
without scanning the negatives as film camera. So digital camera is better. 
Recommended: Nikon D70, D100 and Canon 10D, 20D and 300D. 

 
 Fisheye lens: Fisheye lens can capture an FOV (field of view) of over 180 

degrees. A panorama can be stitched from 2 or more fisheye images. Sigma 
8mm F4 EX DG Circular Fisheye lens is recommended. 

 
 Pano Head: Also known as Panoramic Tripod Head or Rotator is installed on a 

tripod when shooting to eliminate the displacements between fisheye images 
so that the panorama can be stitched seamlessly. Different pano head matches 
different DC. The pano head from Kaidan, Agnos and Manfrotto are compatible. 

 
 Tripod: A tripod is an adjustable three-legged stand used for supporting 

photography equipment when shooting. Because fisheye lens covers a wide 
range of shooting area, it calls for tripod with a not-too-long handle; otherwise, 
the long handle will cover a wide area in the stitched panorama and is difficult 
to be erased. Stableness of the tripod is also important. The tripod from 
Manfrotto and Bogen are recommended. 

 
 Recommended: DSLR + Sigma 8mm lens and stitch 4+T drum fisheye 

image. 
 
 

Digital Camera and Fisheye Lens 

A normal 35 mm camera lens covers an area with 40 degrees HFOV (horizontal field 
of degree) and 27 degrees VFOV (vertical field of degree). It needs many pictures to 
make a 360x180 panorama and is very inconvenient either in shooting pictures or in 
stitching. While with over 180 degree view of angle, the fisheye lens can meet our 
demands. There are three types of fisheye images shot with different equipment 
combination. 
1. Full Circular Fisheye : 
See equipment combination to get full circular fisheye images. Nikon FC-E9, 
more at http://nikonimaging.com/global/products/accessory/converter/fc-
e9/index.htm 

 
 
 
Specifications 
 

Focal length of the camera's lens reduced to 

http://nikonimaging.com/global/products/accessory/converter/fc-e9/index.htm
http://nikonimaging.com/global/products/accessory/converter/fc-e9/index.htm
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x0.2 
Provides approx. 183 degree (COOLPIX 5700) / 
190 degree (COOLPIX 5400) view angle 
6 elements in 4 groups 
Dimensions (approx.): Ø101 x 73mm (Ø4.0 x 
2.9 in.) 

 

Weight (approx.): 580g (20.5 oz.) Fisheye Converter 
FC-E9 

 
2. Drum fisheye image: 
See equipment combination to get drum fisheye images. 
Sigma 8mm f4 ex circular fisheye lens 

 
Specifications 
Focal length: 8mm 
Provides approx. 180 degree view angle 
10 elements in 6 groups 
Dimensions (approx.): 73.5 x 61.8 mm 

 

 

 
 

 
Weight (approx.): 400g Sigma 8mm f4 Ex 

circular fisheye lens 
 

3. Full frame fisheye images 
See equipment combination to get full frame fisheye images. AF DX Fisheye-
Nikkor 10.5mm f/2.8G ED, more at 
http://nikonimaging.com/global/products/lens/af/dx/af_dx_fisheye105mmf_28g_ 
ed/index.htm 

 
Specifications 
Focuses down to 0.14m/0.46 ft. 
Full-frame fisheye images with a picture angle 
of 180 degree (diagonal) 
10 elements in 7 groups 
Filter attachment size: Rear-attachment type 
27mm 

 
 
 

 
 
 
 

Hood: Built-in AF DX Fisheye-Nikkor 
10.5mm f/2.8G ED 

 
 
 
 

Pano Head 

Pano Head is also called tripod panoramic head, or rotator. To understand the 
function of pano head, "nodal point" should be explained first. The nodal point is a 
special point in space, where light enters the lens converges into a point and then 
diverges to impact on the recording medium. As one rotates a camera and shoots a 
sequence of images to later be stitched together, all of the images must be shot with 

http://nikonimaging.com/global/products/lens/af/dx/af_dx_fisheye105mmf_28g_ed/index.htm
http://nikonimaging.com/global/products/lens/af/dx/af_dx_fisheye105mmf_28g_ed/index.htm
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the camera rotating about its nodal point! The pano head is just used for this 
purpose. 

 
A panoramic head is an additional piece of equipment to put on top of a tripod which 
can be small or very large. It allows the camera to be located so that one of the 
nodal points of the lens is perfectly on the axis of rotation. 

 

 
It will cause parallax to shoot with DC and fisheye lens without using pano head. 
Illustration is as below. 
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Note: Above panorama image is stitched from images shot without using a 
pano head. There are obvious misalignments caused mainly by "parallax". By using 
a pano-head, the camera can be rotated to take a set of pictures for making a 
panorama without suffering from "parallax". 
If you want to know how to adjust pano head, you may also refer to 
http://www.panoguide.com/howto/panoramas/setup_panohead.jsp 

 
 
 
 

Tripod 

A tripod is an adjustable three-legged stand used for supporting photography 
equipments when shooting. Because fisheye lens covers a wide range of shooting 
area, it calls for tripod with a not-too-long handle; otherwise, the long handle will 
cover a wide area in the stitched panorama and is difficult to be erased. Stableness 
of the tripod is also important. The tripod from Manfrotto and Bogen are 
recommended. 

 
 
 
 

Compatible Equipment 

 
 
Refer to http://www.easypano.com/pw6-equipment.html for details. 
 
 
 
 

Workflow of Shooting Fisheye Images 

 

http://www.panoguide.com/howto/panoramas/setup_panohead.jsp
http://www.easypano.com/pw6-equipment.html
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Other Accessories 

In addition to preparing all the necessary equipment such as DC, fisheye lens, 
pano head and tripod, preparing some other accessories will facilitate the 
photography process. 
Enough battery: Make sure to charge your battery and enough spare batteries are 
available. 
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 Enough memory cards: Estimate the shot images amounts and the memory of 
the flash card then calculate your needed card numbers. The original flash card 
with the camera is generally 16M. You may purchase different memory card as 
128M, 256M, etc. 

 Computer: Computer is necessary sometimes to store more images. Make sure 
your computer has been installed with USB driver and Nikon View software, 
also with the power cable, USB cable/serial cable, card reader, etc. 

 
 Camera remote cord: Remote cord is helpful in prevent the camera from 

shivering during shooting. Please inquire the local camera store for more 
information. 

 
 Camera bag: A camera bag can be considered for convenience. Inquire the 

local camera shop for more information. 
Check your equipment before hand: 

 Check for enough battery. 
 Observe your fisheye lens and clean it with lens tissue if any smudge. 
 Ensure the tripod stable and level. 

 
 
 
 
 
 

Assemble the Equipment 

 
 
Pano Head can be classified as two types: lens specific pano head and non-lens 
specific pano head. The former is applied to certain lens and cameras, which is 
simple to install since there will be no need locating a nodal point. The latter can be 
used to all the lenses & cameras, however you need to locate the nodal point 
yourself. 
The following chapter will give you instruction on assembling different equipment. 

 
 
Lens Specific Pano Head 
Take the example of Nikon Coolpix 8700 plus FC-E9 fisheye lens plus Agnos 
MrotatorB to assemble the equipment. 

 
Attach the Pano Head to the Tripod 
First attach the pano head to the rotating base of the tripod and screw up. Then fix 
it to the tripod and screw up. Rotate the pano head to assure it can spin smoothly 
around the tripod axis. 
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Mount the Fisheye Lens to the Camera 
First insert your flash card and battery in the DC. To avoid dirtying the fisheye lens, 
do not uncover the lens cap during the assembling process. Hold the DC with one 
hand and the lens with the other hand then rotate the lens gently to tightly fix the 
two together. 

 
 
 
 
 
Attach the Camera to the Pano Head 
Attach the camera and fisheye lens to the pano head and screw tightly with spanner. 
Assure the camera body and horizontal line in a right angle. 
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Non Lens Specific Pano Head 
As we mentioned, pano head is to assure the nodal point perfectly on the axis of 
rotation while rotating the camera. For non lens specific pano head, you need to 
locate the correct nodal point location during installing and then fix them together. 

 
Take the example of Canon 10D plus Sigma 8mm fisheye lens plus Manfrotto 
303SPH to assemble the equipment 

 
Attach Manfrotto 303SPH to the Tripod 
Rotate the pano head to assure it can spin smoothly around the tripod axis. 

 
 
 
 
Attach the Camera to the Pano Head 
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Align the white dot in the lens with the red dot in the camera, then screw up. AF 
(Auto Focus) mode is recommended, as the red circle shown in the lens. 

 
Attach the Camera & Lens to the Pano Head 
Locate the nodal point 
After locating the nodal point, record the value of the three slide plates. Fix the slide 
plates with the right value and screw up the four knobs. Please align No. 4 knob with 
0 degree. 

 
 
 
How to Locate the Nodal Point 
This is one of the most frequently asked questions when it comes to stitcher-based 
panorama creation. Once you understand the basics, you'll be able to easily locate 
the nodal point for any camera and lens combination. Simply speaking, the nodal 
point is the point inside your camera where the light rays converge and flip over. 
When shooting a panorama it's necessary to rotate about this point to eliminate the 
image mismatch caused by parallax error. It's also worth noting that the nodal point 
is not the same as the film plane, which is often marked on the underneath side of 
many 35mm cameras. Generally, for most 35mm cameras and lenses, the nodal 
point is located somewhere towards the center of the lens barrel. Parallax error can 
be easily demonstrated by this simple experiment. Close one eye and hold your 
index finger upright about six inches away from your open eye. Rock your head from 
side to side. Notice how your finger moves with respect to the background. This 
relative movement is due to the fact that you're not rotating your head around your 
eye's nodal point, which is somewhere in the center of your eyeball. Instead, you're 
rotating about your spine which is several inches to the rear and off to one side. It 
is this relative side-to-side motion that we will strive to eliminate when setting up a 
camera for VR panoramas. 

 
 
 
 
Step 1: The side-to-side adjustment 



10 

Once your camera is fastened to your camera bracket, move to the front of the 
tripod head so you're looking into the lens. Adjust the camera bracket so that the 
center of the lens is directly over the pivot axis of the tripod head. Try to be as 
accurate as possible. You should strive to get this adjustment within plus/minus a 
1/16th of an inch. 

 
Step 2: Fore-Aft Adjustment 
This step is most easily accomplished out of doors. Find a vertical edge or line, such 
as a doorway or edge of a building. Locate your camera and tripod about 2-1/2 feet 
away, or as close as possible with the edge still in focus when you look through the 
viewfinder. Look through the camera's viewfinder, find another vertical edge or line 
that is far away, such as another building or telephone pole. Align the two objects 
and rotate the pan head so they are in the left hand side of the viewfinder. Rotate 
the pan head so the two objects move over to the right hand side of the viewfinder. 
Unless you've managed to unwittingly locate the right location, you should notice 
the two objects will move with respect to each other as you rotate the pan from left 
to right. Slide the camera to the front or rear as required to eliminate this relative 
movement. 

 
 
Step 3: Record Your Results. 
After you've discovered the two location dimensions, be sure to record the settings. 
The Kiwi has convenient indicator scales for this purpose. These numbers represent 
the nodal point for this given camera and lens combination. If you change cameras 
or lenses, this procedure may have to be repeated. 
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Step 4: How About Rangefinder Cameras? 
A rangefinder camera is a camera where you look through a separate viewfinder and 
not through the actual lens. The process is basically the same. Locate the 
Side-to-Side adjustment as discussed in Step 1. When it comes to the Fore-Aft 
adjustment, you won't be able to look through the viewfinder to determine the 
proper setting since the viewfinder is a separate optical path that doesn't really 
"see" the same image as the film. Instead, you'll have to start with the bracket all 
the way to the front and take pairs of test shots. Each pair will have the vertically 
aligned objects in the left and then the right side of the viewfinder. After each pair 
of photos, slide the bracket rearward and repeat the process. Slide the bracket the 
same increment each time (i.e. 10mm). Be sure to record the scale setting for each 
pair of images. Process the film, or in the case of digital cameras, download the 
images to your computer. At the end of this process you will be able locate the pair 
of images with the least relative movement. If no single image is optimum, you may 
need to interpolate between two images to find the closest value. 

Note: This part is an abstract from Kaidan User Manual. Thanks Kaidan. 
You may also refer to  http://www.360texas.com/Tips/nodalpts.htm for some 
instruction on Nodal Point location. 

 
 
 
 

Adjust Camera and Shoot Image 

 
 
Preset Camera 
Presetting once is enough when shooting many images for different scenes. 
Set as fisheye mode (Optional) 

Note: DSLR camera need not adjust this. 

For Nikon Coolpix series and some cameras with no fisheye mode, you need to set 
manually before shooting. Here is a brief instruction. 

 
Camera Model Instruction on selecting lens 
Nikon Coolpix 5400 /8700/8400 Go to the menu and select Lens>Fisheye

Nikon Coolpix 4500/995 Go to the menu and select 
Lens>Fisheye1 for full circular fisheye 
shooting; OR Lens>Fisheye2 for full 
frame fisheye shooting. 

Nikon Coolpix 5700 and the DC with no 
fisheye mode 

Macro mode :zoom locked at wide angle 
Exposure metering: Center-Weighted 
Flash modes: Flash Cancel 

 
Adjust the exposure mode 

http://www.360texas.com/Tips/nodalpts.htm
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The word "photography" derives from the Greek and means, literally, "light writing." 
Lighting is mainly controlled by aperture and shutter speed. The shooting modes 
available in most digital cameras range from Auto mode, Scene mode, Programmed 
auto, Shutter-Priority auto, Aperture-priority auto and Manual mode. The latter four 
modes act on panorama shooting and so does the Panorama Assist Mode.  

Note: Please DO NOT use Auto mode for panorama shooting. 

 
 
If you are experienced in photography, Manual mode is recommended to choose 
appropriate aperture and shutter speed according to the environmental light. 

 
If you are a green hand, a usual advice is to choose Aperture priority auto mode. Set 
a larger F value to get a small aperture so that a deeper "Depth of Field" (DOV) is 
achieved with a much wider scope of clear area in the image. (The larger F value is, 
the smaller the aperture is.) For example, F5.0 or F6.0 is better than the default 
F2.5 or F3.3. 

 
Please pay attention if the environmental light is a little dark. Small aperture may 
result in longer exposure time, i.e. shutter speed. The reason is the flash light 
doesn't take effect with fisheye lens since fisheye lens covers a much wider FOV 
than traditional camera lens. Over 1/4 of the shutter speed may bring obvious noise 
in the image. So you have to find a proper value to balance the aperture and shutter 
speed. 

Note: A stable tripod is extremely important if the exposure time is very long. 
 
 
 
Adjust image size and quality 
The fisheye image resolution and quality determine to a great extent the panorama 
quality. The better the fisheye image is, the better the stitched panorama is. Of 
course it occupies more space. So it is recommended to use the largest resolution 
available when shooting. 

 
As to the image quality, “FINE” is all right. “High” can be applied for acquiring high 
quality images. If selecting High, the image size is about 10M so a bigger memory 
card is required. The original file format is TIFF. Camera Raw Image is also available 
in some cameras. 

 
 
 
Adjust Camera 
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Redo the following steps to adjust the camera every time shooting a different scene. 
 
Adjust white balance 
White balance is a name given to a system of color correction to deal with differing 
lighting conditions. Normally our eyes compensate for different lighting conditions, 
but when taking pictures with a digital camera the camera has to find the "white 
point" (the assumption that a white object must appear white) to correct other 
colors cast by the same light. Inappropriate white balance may bring about more 
blue or more red than the original color. 

 
General users can select Auto on White Balance menu. The professionals may select 
“White Bal Preset” or self-adjust the white balance. 

 
Adjust the aperture 
In panorama photography, greater DOV (Depth of Field) helps to acquire a clear 
image in a wider range. Therefore it is important to use a smaller aperture in 
panorama photography than in ordinary photography. To decreases the aperture, 
please increase the F to a value as high as F5.0 or F6.0. 

 
Adjust the shutter speed 
As mentioned in previous chapter, over 1/4 of the shutter speed may bring obvious 
noise in the image. Therefore if the shutter speed is more than 1/4 second under 
Aperture priority auto mode, we suggest you switch to Manual mode. 

 
Adjust the exposure compensation 
After setting the aperture and shutter speed, if the image in the monitor is too dark, 
choose a positive value for exposure compensation. Similarly, if the image in the 
monitor is too bright, raise exposure compensation until the desired effect is 
achieved. 

Note: When shooting two or three fisheye images of the same scene, do not 
change the exposure compensation value. Otherwise it will cause distinct seam in 
the stitched panorama. The following image is an example. In addition, do not raise 
the exposure compensation to a much higher value. It may cause over exposure so 
that the stitched panorama from fisheye images will have a distinct "blue seam". 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: The above panorama image is stitched from images shot with different 
exposure compensation value. There are obvious image brightness differences in 
the two fisheye images' area. 

 
Set AE Lock (Optional) 
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Note: DSLR camera need not adjust this. 
 
Setting AE Lock (Automatic Exposure Lock) is one of the most significant steps in 
panorama shooting. AE lock is the ability to lock the cameras calculated exposure 
settings (aperture, shutter speed, and sensitivity) over a series of images. When 
stitching images together each image should have the same exposure. The flash is 
turned off while AE Lock is in effect. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: Above panorama image is stitched from images shooting without using 
AE Lock. There are obvious image brightness difference in the two fisheye images' 
area and two obvious blue seams resulting from difference exposure value of two 
fisheye images. 

 
After setting the proper aperture and exposure compensation, turn to AE Lock > ON 
in the menu. 

 
 
 
Shoot Fisheye Images 
Please take the following steps strictly. 
 
1. Shoot the first fisheye image 
Place the point of interest in the center of the viewfinder then half press the shutter 
to focus. 

 
2. Shoot the other consecutive fisheye image 
To guarantee the tripod stableness, hold it with one hand. Turn the pano head 
gently with the other hand. Rotate appropriate degrees and take the images around 
360 degrees. 

Note: It is suggested the images be shot clockwise, otherwise, you may have to 
reverse the sequence when loading images in Panoweaver. 

 
3. Shoot top/bottom fisheye (optional) 
Please shoot Top/Bottom fisheye image on the last rotation. For 4 fisheye, please 
rotate pano head up and down to shoot at the 4th location. For 6 fisheye, please 
shoot up and down at the 6th location. You should stay with the last rotation. 
Shooting in some other location will cause an incorrect stitching. 

 
4. Shooting another scene 
After shooting a scene, cover the fisheye lens cap. Move all the equipment to the 
other scene you want to shoot. 
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Note: Turn the “AE Lock Off” otherwise the shutter speed and aperture are 
locked. The shooting procedure is the same as stated above. 

 
5. Import the images to the computer 
After Finishing, import the fisheye images to computer through DC or card reader. 
If the original image has much noise or is not sharp enough, it can be retouched in 
any image editing application such as Photoshop, Fireworks etc. 

 
 
 
Shoot Bracket Images 
Auto bracket exposure is a method to obtain the image with the highest quality. 
Usually camera processes bracket exposure quickly. To shoot the first image, use 
standard exposure value obtained by camera automatically. To shoot the second 
image, use exposure value which is lower a number than that of the first one. To 
shoot the third image, use exposure value which is higher a number than that of the 
first one. 

 
Exposure Value is usually abbreviated as EV and its unit is pace. 
EV is a calculation method to express aperture and shutter. For instance, EV=13 
means several groups of shutter/aperture values of the same EV as 13, such as 
1/30sec, f/16; 1/15, f/22; 1/125, f/8, etc. Please refer to the picture below: 

 
 
The smaller EV value is, the more light camera will take in. 
 
In some old cameras, first set exposure bracket (for instance, press “BKT” button in 
Nikon Camera), and then adjust EV, finally press shutters 3 times consecutively. 
Different cameras have different EV mode, most of which are between -2EV to 
2EV.  The quantity of images is also different. Some cameras shoot 3 images and 
some shoot 5 images. 

 
In most new camera, you just need to set EV and then press shutter once. 
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Camera Raw Image 
A raw image file contains minimally processed data from the image sensor of either 
a digital camera, image or motion picture film scanner. 

 
Raw functions in the same way as film of traditional camera so it contains most 
colors and the widest layers. The excellent feature of Raw is that it saves original 
CCD data to make it much easier for users to edit, keeping the original message 
without revising. 

 
Usually, non-Raw image, even if TIF format has been processed by digital camera. 
As a result, those formats are featured by producers. This is the reason why we say 
"Colorful Sony and Blue Fuji". 

 
Take Canon D100 as example to explain how to set camera to shoot Raw image. 
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Photograph Tips 

 

 
 

Lighting 

 
 
 

 Flashlight will get disabled when using fisheye lens. Selecting a better light is vital 
to get a better image. 10 am to 2 pm is fine for outdoor shooting since it is 
sunshiny. Turn the light on when shooting indoors. 

 DO NOT get overexposure; otherwise, the fisheye images will have a distinct blue 
or dark seam. 

 To get a deeper "Depth of Field", we suggest a larger F value i.e. smaller 
aperture and a longer exposure time. However, exposure time should be less 
than 1/4 to avoid stuck Pixel. 

 Use the Aperture Exposure Lock setting on a digital camera to capture equal 
lighting between hemisphere pictures. If there is a primary light source, 
place it on the seam. This will balance the light between the hemispheres 
and keep overexposure to a minimum. Close blinds or curtains and turn all 
room lights on to even out the lighting on sunny days. 

 Indoor lighting: We often encounter a serious color differences in two interior 
shots. Here is the way to avoid this. Enable your Automatic Exposure LOCK AE-
L and Automatic Focus Lock AF-L. 

 Turn you back to the primary light (Sun or bright window), and turn 90 degrees 
to your left or right and take your first image. Take each image through to the 
end of the image sequence. Turn Off or disable AE-L and AF-L. 

 

 
 
 
 
 

Components 

 
 

 Place the point of interest in the center of the image. Never put it on the seam of 
the fisheye images. 

 Choose appropriate distance and shooting angle to prominently show your 
emphatic object in the image. 

 Pay attention to motion, especially at the image seam. People or animals 
moving across the seam when you take a picture can appear blurred in the final 
panorama image. 

 Make sure to keep any part of your body out of the image area because the 
fisheye lens captures 183 degrees of the area surrounding the camera. 
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Others 

Noise Reduction 
Noise can be summarized as the visible effects of an electronic error (or interference) 
in the final image from a digital camera. It is related with the temperature, 
sensitivity of the sensor (CCD/CMOS) and shutter speed. 

 
Source 1: ISO sensitivity of the sensor (CCD/CMOS): High worse low better. Auto 
shooting mode will automatically increase ISO value when the light is dark thus 
more noise occurs. 

 
Solution: ISO 100 is recommended. Auto shooting mode will automatically 
increase ISO value when the light is dark. 
Please refer to 
http://www.dpreview.com/learn/Glossary/Digital_Imaging/Noise_01.htm. 

 
Source 2: CCD Temperature 

Noise is exponentially related to temperature - it DOUBLES for every 6 or 8 degrees 
C temperature rise (depending on the CCD). 

 
Solution: Store it in a shady cool place before shooting. Do NOT keep the camera 
on for a long time since it will increase the temperature. Turn it off and let it cool 
down before another shot. 
More in http://www.dpreview.com/news/0005/00050104ccdtemperature.asp. 

 
Source 3: Exposure time longer than 1/4s, even to 1-2/s, stuck pixel, i.e. noise, will 
appear in the image. 

 
Solution: Take a second frame known as "dark frame" with the lens covered and 
the shutter closed for the same amount of time as the main image. This dark frame 
will be used to identify and subtract "stuck pixels". Edit the images in Photoshop or 
other software packages to get a cleaner one. 
http://www.dpreview.com/learn/key=noise+reduction has the detail. 

 

 
 
 
Depth of Field 

Depth of Field: Depth of field is the range of distance (measured along the lens axis) 
for which the subject is rendered acceptably sharp in the photographic image. 
The following chart gives the relationship between DOV and its determining factors. 

 Depth of 
Field 

Remark 

F value: 

larger  
Aperture: 

smaller  
deeper Decrease the aperture, i.e. 

increase the F value to get a 
deeper DOV when shooting 
panorama. 

Focal length: 

greater   
shallower Wide-angle lens has deeper DOV 

while telephoto lens has 
shallower DOV. 

Distance from the lens to the 
subject: 

farther  

deeper The closer you are to the subject 
the shallower the depth of field, 
the farther from the subject, the 
greater the depth of field. 

http://www.dpreview.com/learn/Glossary/Digital_Imaging/Noise_01.htm
http://www.dpreview.com/news/0005/00050104ccdtemperature.asp
http://www.dpreview.com/learn/key%3dnoise%2breduction
http://www.dpreview.com/learn/key%3dnoise%2breduction
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Shutter speed 
 

Shutter speed type Required setting or 
equipment 

Applied occasion 

Bulb,1s,1/2s Cameral stableness 
specially  needed, using 
tripod 

For dark scene 

1/4,1/8 Tripod needed 
1/15,1/30,1/60,1/125, 
1/250,1/500 

 For common shooting 

1/1000 Set larger aperture size, 
shallower DOV and 
accurate focus 

Used for sports 
photography as skiing, 
basketball. 

1/2000-1/8000 Telephoto lens equipped Ultra high speed 
shooting, such as sport 
shooting. 

 
The quality of stitched panorama greatly relies on the photography, for 
instance the lighting, contrast, brightness, noise etc. So more knowledge about 
photography is of great help. 
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