panorama software,virtual tour software
Alternate Text
Joined: 2005-07-20
Send Msg:
Posts: 26
2006-01-03
#1

Code base

My applets have suddenly started to fail and I can't figure out why.

The wierd thing is they all work on my local machine but when uploaded to the server the won't work.

This works
http://www.the360co.com/virtual_tours_work/glaunsharoon/twobed_livingroom/livingroom.htm

But if I call that panorama from a html page not within the root folder of the JAR file etc it fails to load.
http://www.the360co.com/virtual_tours_gallery/glaunsharoon.htm

I've checked the code base path and it's fine.

I'd be grateful for any help.

Many thanks

 


Alternate Text
Joined: 2005-07-20
Send Msg:
Posts: 26
2006-01-24
#2
Thanks - got it sorted. We're hoping to move over to Quicktime for all our virtual tours soon.
Alternate Text
Forum Moderator
Joined: 2002-11-23
Send Msg:
Posts: 5438
2006-01-03
#3

Suddenly?

You have failed to upload (or upload to the correct directory)

http://www.the360co.com/virtual_tours_gallery/glaunsharoon.htm

http://www.the360co.com/virtual_tours_gallery/ is missing from it's dirctory

  • ptviewer.jar
  • test1.jpg
  • wait.gif

and I have to ask why you have a new pop up window for each pano? Doesn't make sense. Your code base is also strange you didn't use PTViewer Scripter to produce that code. What image did you think you where going to show in the applet as default?

Regards, Smooth

 


Alternate Text
Joined: 2005-07-20
Send Msg:
Posts: 26
2006-01-05
#4
Thanks Smooth.

Leaving aside the seperate new window issue for the moment OK?

I want to explain my problem again more clearly.

All my Java - based panoramics are working on my local machine. Great!

It's when I uploadsome of the html pages to the server that certain panoramics stop working. All the pages that DON'T work sit outside the root folder of the JAR file and use the CODEBASE to locate the JARs...

Specific examples are below.

.........................................................................................

All the Panoramics work when the html page is within the same directory as the JAR files. No probs there.
Example URL which works beautifully
http://www.the360co.com/virtual_tours_work/glaunsharoon/twobed_livingroom/livingroom.htm

.........................................................................................

The page below however sits on a different folder level and thus calls the panoramic in the first example by using the codebase code to locate all the JAR files etc

http://www.the360co.com/virtual_tours_gallery/glaunsharoon.htm

codebase="../virtual_tours_work/glaunsharoon/twobed_livingroom/"

.........................................................................................

Why is this not working on the server when it is working on the local machine? The path is correct

It's really frustrating me at this stage.
Many thanks
P

Alternate Text
Forum Moderator
Joined: 2002-11-23
Send Msg:
Posts: 5438
2006-01-05
#5

That is NOT how you set the path. If you want to use the single .jar file then you set it's path not the codebase (I'm not 100% sure where you even got that from)?

It would be ptviewer.jar = "../virtual_tours_work/glaunsharoon/twobed_livingroom/" and this is only relevant to the .jar file not the pano image or the loading and wait images. These paths would need to be set in the PARAMETERS

Absolute paths are recommended, Not Relative paths.

Your  http://www.the360co.com/virtual_tours_work/glaunsharoon/twobed_livingroom/livingroom.htm works correctly because all the relative files are in the correct place and you haven't set relative paths in the wrong place.

Regards, Smooth