panorama software,virtual tour software
Alternate Text
Joined: 2009-09-18
Send Msg:
Posts: 7
2009-09-22
#12
Thanks, smooth. I'm away for a couple of days. I'll test this as soon as I return and I will post my results here. But I think I have already tried what you are suggesting, unfortunately without succes.


Alternate Text
Joined: 2005-07-07
Send Msg:
Posts: 772
2009-09-23
#13
As Smooth says have a look at the ones he mentioned - they have much better features and much more forum support than the Longtion software but I had a problem getting a virtual tour to sit well on a page and last time I tried I had a problem with it asking to install flash (when I had and it was).  No one on the forum was able to help so I stayed with Longtion.  Longtion is cheaper but lacks many of the tasty features on the other ones.
sales@actualeducation.co.uk
www.actualeducation.co.uk
Alternate Text
Joined: 2009-07-24
Send Msg:
Posts: 25
2009-10-06
#14
Hi Smooth, thanks again for your help!
As far as I understand this, it's definitely not the problem with the path in autorun file, as I can open the first tour with no problems, but than the link in this first tour (that points to another tour) does not open. There's a small printscreen, I hope it makes things clear.

Sorry to bother you, but what exactly do you mean by "the full file structure"? As you can tell, I'm really confused about this wole thing at the moment ...
Alternate Text
Forum Moderator
Joined: 2002-11-23
Send Msg:
Posts: 5438
2009-10-06
#15
%cdroot%
               /fscommand/
                                  tourfolder1/Tourweaver_tour1.html
                                  tourfolder2/Tourweaver_tour2.html
                                  tourfolder3/Tourweaver_tour3.html

Address to tour1:
/fscommand/tourfolder1/Tourweaver_tour1.html

Address to tour2:
/fscommand/tourfolder2/Tourweaver_tour2.html

etc.

Yours at the moment is very wrong:

%cdroot%
               /fscommand/
                                 tourfolder1/
                                                  .../fscommand/
                                                                         tourfolder1/Tourweaver_tour1.html
                                                                                        
fscommand/tourfolder2/.../fscommand/tourfolder1/Tourweaver_tour1.html
                                                                                    
Regards, Smooth
Alternate Text
Joined: 2009-07-24
Send Msg:
Posts: 25
2009-10-06
#16
Yea, I see that the path there is, as you said, very wrong, but here is the problem: My folder looks exactly like this:

cdroot
               fscommand/
                                  _flashvr1/Tourweaver_tour1.html
                                  _flashvr2/Tourweaver_tour2.html


In tourweaver, I try to include a link in tour1 that would point to tour2, so I use Link to url option and put in:

fscommand/_flashvr2/Tourweaver_tour2.html


Than, when the project is exported, the link is changed to the one that obviously cannot work:

fscommand/tourfolder2/.../fscommand/tourfolder1/Tourweaver_tour1.html



I know I must be doing sth wrong, but don't know what ...

Thanks for your patience! :)
                            
Alternate Text
Forum Moderator
Joined: 2002-11-23
Send Msg:
Posts: 5438
2009-10-07
#17
Pingus_,

Like a said it has been awhile since I have done any of these. So rather then sent you further up the garden path I thought I better test it. So I made a CD to see that it does in fact work.

The hyperlink URL address you enter for a "hotspot" must be as follows (sample).

/fscommand/_flashvr2/Tourweaver_tour2.html

It must have the "/" before the fscommand. When typing this into Tourweaver and be sure to dismiss the http:// completely (remove it) before typing in your hyperlink address.

Within Tourweaver when setting the path also choose: Destination = _self

This structure is correct:

%cdroot%
               /fscommand/
                                  tourfolder1/tourweaver_tour1.html
                                  tourfolder2/tourweaver_tour2.html
                                  tourfolder3/tourweaver_tour3.html

Before burning to a CD test the hotspots locally (although they won't work) it will show you the path (as an error) something like: C:/fscommand/tourfolder/tourweaver_tour2.html

What this shows is that it is skipping the "cdroot folder" and looking directly to the "C" drive for the next file (wrong location). But once this is burnt to a CD it will find the tour because the "C" is replaced by the CD drive letter.

Your autorun.inf file will need the address changed to match. I.E:

[autorun]
shellexecute=/fscommand/tourfolder1/tourweaver_tour1.html


This you can edit with any text editor like "Notepad".

Remember we only burn the contents of the CDROOT folder not that folder itself.

You burn:

fscommand (and it's contents)
autorun.inf

I hope this makes sense?

Regards, Smooth
Alternate Text
Joined: 2009-07-24
Send Msg:
Posts: 25
2009-10-09
#18
Hi Smooth!
Thanks for all the explanations, after so many posts I start to feel a bit embarrassed to bother you further, but I'm struggling to meed my deadline with the current project ... After two nights of testing all possible options I still can't get it to work. I did everything what you have written above, the files&folder structure is as it should be, the url address is the same as your example. After that, the link is not working at all. When clicking on it, nothing happens. As if there was no link at all. I have no idea what happens with it. In the past few days, I've tried everything I could possibly think of to solve this issue, but nothing worked. Have you got any clue about what I may be doing wrong?
Thanks a lot!
Alternate Text
Forum Moderator
Joined: 2002-11-23
Send Msg:
Posts: 5438
2009-10-09
#19
The only time I have ever seen them not work was because of a crappy low quality brand of CD and a CD drive struggling to read from the disk. Once in another computer it worked fine.

Can you send me a zip of your folder structure with the heavy part of the tours striped out?

Make a complete copy and then remove all tour items but the .html files and then zip them all up.

Supply me a download link here or via PM

Regards, Smooth
Alternate Text
Forum Moderator
Joined: 2002-11-23
Send Msg:
Posts: 5438
2009-10-10
#20
Pingus_,

I download and inspected your files.

You have made some very simply file naming mistakes (multiple!).

Your Autorun points to address:

/fscommand/flashvr_1/rcn_dravinja.html

Your hotspot points to:

/fscommand/_flashvr2/rcn_gozdna.html

The current actual address is:

/fscommand/flashvr_2/rcn_gozdna.html.html

But note when looking in your folder that the HTML file has double .html.html of rcn_gozdna.html.html

Speaking of folders your second folder (the hotspot location) is called flashvr_2 but your hotspot points to a folder called _flashvr2

Spot the difference?

/fscommand/_flashvr2/rcn_gozdna.html.html
/fscommand/flashvr_2/rcn_gozdna.html

I suggest you check and pay close attention to all your file names and their spelling. Easy to spot with fresh eyes.

After I corrected these mistakes I was able to burn to a CD and watch back on another PC no problem.

Let me know how you get on.

Regards, Smooth
Alternate Text
Forum Moderator
Joined: 2002-11-23
Send Msg:
Posts: 5438
2009-10-12
#21
I will state that at this stage this ONLY works with Internet Explorer browser. It fails using Firefox, Opera, Chrome and Safari browser because of the "localhost" limitations.

I will continue to look for an answer. Should you know of a work around I'm sure we all would like you to share.

Regards, Smooth