panorama software,virtual tour software
Alternate Text
Joined: 2012-06-13
Send Msg:
Posts: 44
2012-06-13
#1

Some issues with uploading

Hi all, I'm new here.
I'm using 6.5 trial version but i get some problems when i try to see the tour on my webspace.
Firstly, loading stopped at 10%, with the green bar blocked. I solved this issue removing twviewer.swf from the web folder, and replacing it with the same file produced by TW v. 6, as someone suggested on this forum. But what's wrong with twviewer.swf made by TW 6.5?
Secondly, I still can not see the Google/Bing maps viewer online. It perfectly works locally, but when online it disappears. Why?
Thanks for help.
Alessandro
Alternate Text
Forum Moderator
Joined: 2002-11-23
Send Msg:
Posts: 5438
2012-06-13
#2

You should not need to swap out the twviewer.swf file.

Likely cause is the panorama image being too large. Keep under 8000px wide.

Google and Bing maps require an API key generated for the domain in question. Google Maps is no longer supporting Flash so if you didn't get a Flash API long ago you will have to use Bing maps.

Welcome to the Easypano forum.

Regards, Smooth [8D]


Alternate Text
Joined: 2012-06-13
Send Msg:
Posts: 44
2012-06-13
#3
Thankyou Smooth for your quick reply.
There are many panoramas in my tour but I resized them all down to about 2000px long side. So I don't think they are too heavy.
About map viewer, I have a Bing map key, I entered it in the proper form, along with the coordinates, but I have no Bing maps visible online nevertheless. Locally it works great.
Do I get these problems maybe because of some limitations of trial version?
Thanks again
Alessandro
Alternate Text
Forum Moderator
Joined: 2002-11-23
Send Msg:
Posts: 5438
2012-06-13
#4

Images don't sound too big. Maybe your Flash browser plug-in isn't up to date? There was a change from Flash 9 to Flash 11. 

Bing maps work fine under an English working Windows environment. Problems happen when "commas", are use instead of "decimal point". in GPS co-ords, this is something we have covered before on the forum.

Showing screen captures may help!  

There shouldn't be any difference between trial or full version other than watermark or trial splash screen appearing.

Regards, Smooth [8D]


Alternate Text
Joined: 2012-06-13
Send Msg:
Posts: 44
2012-06-13
#5
My Flash Player plug-in version is 11.2.202.235, and ActiveX version is 11.3.300.257. Don't know what difference there is.
You have a screen shot of the online tour here
and the same tour published locally here
Thanks again,
Alessandro
Alternate Text
Forum Moderator
Joined: 2002-11-23
Send Msg:
Posts: 5438
2012-06-13
#6

I would need to see your API key and how you have entered it into Tourweaver.

It is extremely important that you don't have a space at either end of the key. (This is a common mistake.) Be sure to read this thread

Confirm your key with your Bing account and triple check it with your Tourweaver GUI.

Regards, Smooth [8D]


Alternate Text
Joined: 2012-06-13
Send Msg:
Posts: 44
2012-06-15
#7
I tried again and again to make the things work, but I'm still having that issue, can not see Bing maps viewer online.
I tried to insert very carefully a new key from Bing, but no success. May a possible cause be in the free web space I've set as domain in the key registration process?
Oh, if I don't swap twviewer.swf with the one made by v.6, loading bar still stays blocked at 10%, who knows why...
I have Windows 7 fully updated. I think I'll buy a full version of TW 6.5 soon, but before doing that I'd like to know if (and how) I can fix this problem.
Many thanks again,
Alessandro
Alternate Text
Joined: 2012-06-13
Send Msg:
Posts: 44
2012-06-19
#8
any other ideas?
Thanks again.
Alessandro
Alternate Text
Forum Moderator
Joined: 2002-11-23
Send Msg:
Posts: 5438
2012-06-19
#9

Alessandro,

All I can do is have a look at your "complete" project file.

You would need to .zip the whole thing up and upload it to a server and then provide me with the download link. I don't need or want the "published" tour.

You can send the link via Private Message if you like. I will also need your Bing key and what the URL is you have associated with.

I assume you followed "all" the instructions provided in the previous replies and thread links?

Regards, Smooth [8D]


Alternate Text
Forum Moderator
Joined: 2002-11-23
Send Msg:
Posts: 5438
2012-06-20
#10

Hi Alessandro,

I received your tour and tested on my server with my domain API key and it appears to work fine.

It could be your free space host or you may need to obtain your API key for either the domain only or possibly with the sub domain included.

I have sent you a link to confirm the tour is working with Bing maps. Let me know the result.

Regards, Smooth [8D]