panorama software,virtual tour software
Alternate Text
Joined: 2008-12-23
Send Msg:
Posts: 142
2015-01-22
#1

Review TW7.95 Comments and Bugs

Easypano.


I was very excited to see the release of TW7.95, but at the same time fearing the possibility of dealing with many bugs like previous versions.  To my surprise I was very excited about the results I got from my initial testing. Overall I would say that this version exceeded my expectations and I love some of the new features that are available.


Here is a list of some the issues I encountered while working with the latest version:

1. Within the loading window the loading bar is not correctly anchored to the center on export in flash or html5.  

            so.addVariable("lwBarBounds", "60,-276,154,6");
            so.addVariable("lwlocation", "7");


2. When trying to select a color from the swatches panel I found it difficult to select a color.  When trying to select a color it would pick the color but not change on the tour and would revert back to the last color selected.  After playing with it for a while I discovered that if you click the color selection button and do not release the mouse until you hover over the color you want the selection would work, but if you clicked the color selection button and released the mouse and then clicked the color you wanted it would fail to select it.


3. When you add a sound to a scene and have background music for the entire virtual tour they will not play at the same time, but if you start a video while a scene sound is playing they play at the same time instead of only playing the audio form the video clip.


4.The sound controller does not work in HTML5 (IOS) as you slide the bubble back and forth nothing happens (does work if you test on a desktop in firefox). In Flash the controller works but it only shows the bubble not the white line to the left.


5. When using a toggle button and adding the mute/sound action it works fine in flash, but in HTML5 the button has issues... when the tour starts the muted state is showing and when you click the button it mutes but shows the unmuted state of the button... at first I thought it may be that the images are flopped but after more testing I think it has somehthing to do with the actions.  So for instance the action description says (stop/replay sound) so if you let the entire sound clip play and click on the muted button state it starts the audio over and now shows the correct state of the button. So there is something wrong with the action itself I believe.  It shouldn't replay a sound it should just start or stop it.


6. The Still Image action shows the image but when zooming in or our the quality isn't very good.


Suggestions:

1. When creating a popup allow the user to choose an anchor point for the box from the menu  Currently you have to creat the popup and then go to the properties panel at the bottom to select the anchor point.


2. Is there away to control the size of the virtual tour as it appears on different devices?  So for instance on an iPhone 5s I took a screen capture and see that everything is exactly the same dimensions as the tour I created, but on an iPad Air the tour scales (just the graphics not the actual panos). So instead of a height of an image at 90px its 180px.  It looks fantastic on both devices, but it would be nice if I had the ability to scale it on iPhones or smartphones because some of the of the content does get a bit small.  It already apprears that there is some way to do this because between the iphone and ipad air they are showing at different sizes. Does this have to do with smartphones vs. tablets?  Is there something I can do right now? Is there some sort of menu option easypano can create to allow us to choose how it displays? Or maybe is there a way to develop a controller that the viewer can scale the tour smaller or bigger depending on their display and preference?

???

<meta name="viewport" content="target-densitydpi=device-dpi, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, minimal-ui" />

???


There may be other issues that I did not come across, but all in all i am very happy with the progress of TW7.95.  Keep it up Easypano and fixes to these bugs will make me very excited.


Thanks again.


interactive360
Alternate Text
Forum Admin
Joined: 2014-07-16
Send Msg:
Posts: 118
2015-01-22
#2

Hello,


Thanks for your feedback and advice.


1. The problem of choosing the color is existing in some machines. I've taken it to developers.


2. The sound controller does not work in iOS because in iOS the volume property is not settable in Javascript. Please refer the note from Apple: https://developer.apple.com/library/safari/documentation/AudioVideo/Conceptual/Using_HTML5_Audio_Video/Device-SpecificConsiderations/Device-SpecificConsiderations.html

We'll find out a solution in next version.

3. The toggle button. I have tested and it works fine here. See the H5 tour published by TW795: http://gallery.easypano.com/test/helen/nd/0122/_html5/Project6.html Maybe you could send me your link or project.


4. About the video's sound. Do you mean local video or Youtube video? The sound of the Youtube video is played at the same time with other sound. It's sort of technical matter. We'll try to fix it if possible.  


Alternate Text
Joined: 2008-12-23
Send Msg:
Posts: 142
2015-01-23
#3

1. Thank you for looking into the color selection problem.


2.I understand that the sound control has issues with IOS so when you find a solution that would be great. If you can get the toggle button working (see #3 for update) then this issue is not much of a concern


3. So I see that the toggle button with the sound works in your example and I tried it on my own tour as well and discovered that if you use a color or text it shows correctly, but if you add images then the toggle doesn't show the correct state of the button.  Like I mentioned it works in flash but not html5. Also even in your example if you allow the audio to play all the way to the end and once it ends you go to mute the audio it changes to the muted state and then replays the audio clip.  So in other words the action needs to be adjusted.


4. I tested the sound from a local file not youtube, so I do not know if this will make a difference.  I guess you guys will have to test it on your end.


5. I have also noticed that each scene is creating a very big exported folder in html5.  A 2 MB scene exports to 30 MB. Why are they getting so big?


6. You never commented on the issues of the background sound clip and scene sound clip not playing at the same time.


7. Also can you ask the developers about my question on scaling for different smartphone resolutions.




interactive360
Alternate Text
Forum Admin
Joined: 2014-07-16
Send Msg:
Posts: 118
2015-01-23
#4

Hello,


Any sound will not play with each other at the same time. Some users prefer a sound independently while others not. So we just keep it inependent (except Youtube video).

Here's the priority:

sound of video> sound triggered by Button> sound of scene> sound of movie> background sound


About panorama's size. Normally it will not be that big as you said. Below is the property of one of the scene folder in HTML5 folder. And the original size of the panorama is 1.79MB. Maybe you can send me the project.


Issues of toggle button with image and the size of tours for mobile devices are what we work on. Any news, I'll let you know.


Alternate Text
Joined: 2008-12-23
Send Msg:
Posts: 142
2015-01-23
#5

1. Why not allow the user to decide if they want the audio clips to play seperate or together?  For instance I like to have some background music playing with a voice-over that plays with the scene.  Also I tested your priority list and discovered some things... you are correct with most of it, but a local video still plays over the top of anyother audio that is currently playing.  A video should always mute any other audio because it becomes quite difficult to hear two audio tracks playing especially when watching a video.


2. Not sure what's going on with file sizes when exporting but i noticed some scene folders have 331 or 85 or 182 files in a folder... why would they have different numbers of files? You can test this with a sample you provide in the TW launch window.


3. Forgot to ask in the last post if you have found out anything on the anchor point for the loading bar in the loading window?


interactive360
Alternate Text
Joined: 2013-01-28
Send Msg:
Posts: 15
2015-01-24
#6

I have installed TW 7.95 I go to run the the program but I just get the message "program has stopped working". I have tried installing several times also I downloaded it again but I still have the same problem.


I am running on Win 8.1, 64 bit,Intel i7 quad core cpu, 32gig ram.


any ideas?


Regards,


Paul


360Turismo

Alternate Text
Forum Admin
Joined: 2014-07-16
Send Msg:
Posts: 118
2015-01-26
#7

I have installed TW 7.95 I go to run the the program but I just get the message "program has stopped working". I have tried installing several times also I downloaded it again but I still have the same problem.


I am running on Win 8.1, 64 bit,Intel i7 quad core cpu, 32gig ram.


any ideas?


Originally posted by Paul on 2015-01-24 21:17


Have you run TW earlier versions before? Maybe we can remotely assist you via Teamviewer.

My email: helen@easypano.com Please contact me and make the time if you would like.


Alternate Text
Joined: 2013-01-28
Send Msg:
Posts: 15
2015-01-28
#8

Hi Helen,


I have 6.5 and 7.5 installed and work with no problems.

When I install 7.9 and then run it the app just crashes!


Regards,


Paul


360Turismo

Alternate Text
Joined: 2013-01-28
Send Msg:
Posts: 15
2015-01-28
#9

Sorry I meant When I install 7.9.5 and then run it the app just crashes!


Regards,


Paul


360Turismo

Alternate Text
Forum Admin
Joined: 2014-07-16
Send Msg:
Posts: 118
2015-01-28
#10

Hi Helen,


I have 6.5 and 7.5 installed and work with no problems.

When I install 7.9 and then run it the app just crashes!


Originally posted by Paul on 2015-01-28 01:21



Hi Paul,

It's suggested to have a remote assistance via Teamviewer to see what happened in it. I'm online from 10 AM to 5 PM, UTC +8. Please let me know if you are available to connect with me and send me the ID and password via email or skype.

My email: helen@easypano.com

Skype: easypanosupport

Thanks!


Alternate Text
Forum Admin
Joined: 2014-07-16
Send Msg:
Posts: 118
2015-02-13
#11

Hi,

To solve the problem of picking the color, please download the file and replace the file of the same name in Directory of Tourweaver 795. Hope to hear your feedback again. Thanks!

http://gallery.easypano.com/test/helen/nd/0213/STControl.dll